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1. Before you start 
1.1. About this manual 

The documentation for your software consists of three parts: the installation 
manual, the online help, and this manual.  

The installation manual is delivered with your software. There, you can find the 
system requirements. Additionally, you can find out how to install and configure 
your software. 

In the manual, you will find both an introduction to the product and an explanation 
of the user interface. By using the extensive step-by-step instructions you can 
quickly learn the most important procedures for using this software. 

In the online help, you will find detailed help for all elements of the program. An 
individual help topic is available for every command, every toolbar, every tool 
window and every dialog box.  

New users are advised to use the manual to introduce themselves to the product 
and to use the online help for more detailed questions at a later date.  

In this documentation, the term "your software" will be used for OLYMPUS 
Stream. 
 

During the installation of your software some sample images have been installed, 
too. These example images might be of help to you when you familiarize yourself 
with the software. Regarding the information as to where the example images are 
located, please refer to the online help. 
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1.2. Online help for your software 
In the online help, you will find detailed help for all elements of the program. An 
individual help topic is available for every command, every toolbar, every tool 
window and every dialog box.  

When you use the online help you'll have access to most online topics. As soon 
as you access the online help you will find yourself in the help mode. In the help 
mode, a question mark will be attached to the mouse pointer. Then you will be 
able to call for help on almost all of your software's functions.  

There are various ways of switching to the help mode. 

 Click the Context Help  button. You will find this button on the 
Standard toolbar. 

 Use theHelp > Context Help command.  
 Use the [Shift + F1] shortcut. 
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1.3. About your software 
Please note: Not every software package contains all of the features! 

To support the different requirements of our customers optimally, a variety of 
packages are available for your software. The larger packages contain more 
features than the smaller packages. For example, the smaller packages contain 
no database functionalities.  
Some of the functions described are, therefore, of no relevance to users of 
smaller packages. 

Where do you find 
which information? 

Writing convention 
used in the 

documentation 

Example images that 
are automatically 

installed 

Switching to the 
 help mode 
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Main features of your software 
You can use your system to acquire high resolution images of a sample in a few 
steps. Your system is comprised of your software and the hardware, e.g., 
microscope and camera. During image acquisition, the data from the camera 
which is mounted on your microscope will be read out and displayed on your PC 
monitor.  

You can first examine the live-image and adjust it optimally. The live-image will 
be constantly updated, i.e., when you, for example, move the stage to a different 
position, the live-image will be changed accordingly. You can switch the live-
image on and off and acquire a photo of the parts of the sample that interest you. 
When you do this, you will create a digital image that you can save and process 
or analyze with a variety of your software's functions. 

A multi-dimensional image is always made up of several frames. These have, for 
example, been acquired at different times, or in different focus positions. With 
your software you can, e.g., acquire a time stack or a Z-stack. For optimum 
viewing of multi-dimensional images, use the separate navigation bar that is 
shown directly in the image window when a multi-dimensional image is loaded. 

With your software, you can acquire images which have a practically unlimited 
depth of focus. These images are called EFI images. EFI is the abbreviation for 
"Extended Focus Image". For the creation of an EFI image, the software 
determines which of the pixels from the differently focused frames in a Z-stack 
are the sharpest, and calculates an image that is sharply focused in all areas 
from them. 

When your system is equipped with a motorized XY-stage: Use the XY-Positions 
/ MIA acquisition process to acquire a stitched image of a larger part of the 
sample. MIA stands for Multiple Image Alignment. During the acquisition, this 
acquisition process directly combines all of the images that are acquired, into a 
stitched image, just like a puzzle.  

When your system is not equipped with a motorized XY-stage: Use the Manual 
MIA acquisition process and manually move the stage to have the different, 
adjoining parts of the sample put on display one after the other. By using this 
acquisition process directly during the acquisition, you combine all of the images 
that are acquired into a stitched image, just like a puzzle. 

You can insert not only images, but also documents which have another file 
format, into a database. That enables you to store all manner of data that 
belongs together, in one location. Search and filter functions make it quick and 
easy to locate documents. 

Images will, by default, be saved in the TIF or VSI format. If you save an 
acquired image in TIF format, a lot of important image information will be 
automatically saved with it, for example, data concerning the camera used, the 
exposure time, the resolution, the time of creation, and so on. You can later view 
this data again whenever you want, simply by opening the image with your 
software. You do not need to collect this data separately. 

You can make various measurements on images, and, e.g., measure the length 
of a line, the perimeter of an ellipse or an angle in degrees. The measurement 
objects will be displayed in the image's drawing layer, and can be faded in and 
out. The measurement results will be shown in a sheet and can be differently 
sorted by a click of your mouse. You can export measurement results, for 
example, to the XLS format (for further editing in the MS-Excel application 
program). 

You can measure an image, or several images at the same time, according to 
different material science analysis processes.  
The Materials Solutions tool window works similarly to a software wizard. As 
soon as you've started an analysis process you'll be guided step by step through 
the measurement.  

Acquiring images 

Acquiring and viewing 
multi-dimensional 

images  

Acquiring an EFI image 

Acquiring stitched 
images 

Saving documents  
in a database 

Measuring images 
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The following material science analysis processes are available: 

 Intercept analysis 
 Grains Planimetric 
 Chart comparison 
 Layer thickness measurement 
 Cast Iron Analysis 
 Inclusion worst field analysis 

You can process the acquired images and retroactively optimize the image 
quality according to your requirements. Numerous filters and functions are 
available for this purpose, e.g., various smoothing or sharpness filters, and 
functions to optimize the contrast. As well as this, you can mirror the images and 
also rotate them through an arbitrary number of degrees. 

With an automatic image analysis, your software searches for areas in an image 
that have the same intensity, or color. All of the areas that have the same 
intensity, or color will be assigned to a phase, and evaluated. This makes it 
possible to automate typical measurement tasks. You can, for example, 
determine the area ratios of the different phases in an image. 

You have the possibility to document the results of your work in a report. To do 
this, select the required page templates and images in the Report Composer, 
and generate an MS-Word report.  

You can control your microscope's motorized parts via the software. For 
example, you can change an objective, load an ND filter, or open and close a 
shutter, with your software. To make this communication function, the 
components must not only be motorized, but also have been configured in the 
software. 

00017 

Processing images 

Analyzing images 
automatically 

Creating reports  

Controlling the 
microscope 



User interface

 

8 

2. User interface 
2.1. Overview - User interface 

The graphical user interface determines your software's appearance. It specifies 
which menus there are, how the individual functions can be called up, how and 
where data, e.g. images, is displayed, and much more. Here, the basic elements 
of the user interface are described. 

Tip: Your software's user interface can be adapted to suit the requirements of 
individual users and tasks. You can, e.g., configure the toolbars, create new 
layouts, or modify the document group in such a way that several images can be 
displayed at the same time. 

 
The illustration shows the schematic user interface with its basic elements.  
 
You can call up many commands by using the corresponding menu. Your 
software's menu bar can be configured to suit your requirements. Use the Tools 
> Customization > Start Customize Mode... command to add menus, modify, or 
delete them. Further information is available in the online help. 

The document group contains all loaded documents. These can be of all 
supported document types.  
When you start your software, the document group is empty. While you use your 
software it gets filled - e.g., when you load or acquire images, or perform various 
image processing operations to change the source image and create a new one. 

Commands you use frequently are linked to a button providing you with quick 
and easy access to these functions. Please note, that there are many functions 
which are only accessible via a toolbar, e.g., the drawing functions required for 
annotating an image. Use the Tools > Customization > Start Customize Mode... 
command to modify a toolbar's appearance to suit your requirements. 

Tool windows combine functions into groups. These may be very different 
functions. For example, in the Properties tool window you will find all the 
information available on the active document.  

In contrast to dialog boxes, tool windows remain visible on the user interface as 
long as they are switched on. That gives you access to the settings in the tool 
windows at any time. 

The status bar shows, e.g., a brief description of each function. Simply move the 
mouse pointer over the command or button for this information.  
You can also find additional information in the status bar. 

00108 
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2.2. Overview - Layouts 
Your software's user interface is to a great extent configurable, so that it can 
easily be adapted to meet the requirements of individual users or of different 
tasks. You can define a so-called "layout" that is suitable for the task on hand. A 
"layout" is an arrangement of the control elements on your monitor that is optimal 
for the task on hand. In any layout, only the software functions that are important 
in respect to this layout will be available. 

Example: The Camera Control tool window is only of importance when you 
acquire images. When instead of that, you want to measure images, you don't 
need that tool window. 
That's why the "Acquisition" layout contains the Camera Control tool window, 
whereas in the "Processing" layout it's hidden. 

 
The illustration shows you the elements of the user interface that belong to the 
layout. The layout saves the element's size and position, regardless of whether 
they have been shown or hidden. When, for example, you have brought the 
Windows toolbar into a layout, it will only be available for this one layout. 
(1) Toolbars 
(2) Tool windows 
(3) Status bar 
(4) Menu bar  

To switch backwards and forwards between different layouts, click on the right-
hand side in the menu bar on the name of the layout you want, or use the View > 
Layout command.  

For important tasks several layouts have already been defined. The following 
layouts are available: 

 Work with a database ("Database" layout ) 
 Acquire images ("Acquisition" layout)  
 View and process images ("Processing" layout) 
 Generate a report ("Reporting" layout ) 

In contrast to your own layouts, predefined layouts can't be deleted. Therefore, 
you can always restore a predefined layout back to its originally defined form. To 
do this, select the predefined layout, and use the View > Layout > Reset Current 
Layout command. 
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2.3. Document group 
The document group contains all loaded documents. These can be of all 
supported document types.  

 

 
On the left, the illustration shows a schematic representation of a user interface. 
On the right, the document group is shown enlarged.  

(1) Document group in the user interface 
You will find the document group in the middle of the user interface. In it you will 
find all of the documents that have been loaded, and naturally, all of the images 
that have been acquired also. Also the live-image and the images resulting from, 
e.g., any image processing function, will be displayed there.  

(2) Document bar in the document group 
The document bar is the document group's header.  

 
For every loaded document, an individual field will be set up in the document 
group. Click the name of a document in the document bar to have this document 
displayed in the document group. The name of the active document will be 
shown in color. Each type of document is identified by its own icon. 

(3) Buttons in the document bar 
At the top right of the document bar you will see several buttons. 

 
Click the button with a hand on it to extract the document group from the user 
interface. In this way you will create a document window that you can freely 
position or change in size.  

If you would like to merge two document groups, click the button with the hand in 
one of the two document groups. With the left mouse button depressed, drag the 
document group with all the files loaded in it, onto an existing one.  

You can only position document groups as you wish when you are in the expert 
mode. In standard mode the button with the hand is not available. 

The arrow buttons located at the top right of the document group are, to begin 
with, inactive when you start your software. The arrow buttons will only become 
active when you have loaded so many documents that all of their names can no 
longer be displayed in the document group. Then you can click one of the two 

Appearance of the 
document group 

  Button with a hand 

 Arrow buttons 
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arrows to make the fields with the document names scroll to the left or the right. 
That will enable you to see the documents that were previously not shown.  

Click the button with a cross to close the active document. If it has not yet been 
saved, the Unsaved Documents dialog box will open. You can then decide 
whether or not you still need the data.  

(4) Navigation bar in the image window 
Multi-dimensional images have their own navigation bar directly in the image 
window. Use this navigation bar to specify how a multi-dimensional image is to 
be displayed on your monitor, or to change this. 
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2.4. Tool Windows 
Tool windows combine functions into groups. These may be very different 
functions. For example, in the Properties tool window you will find all the 
information available on the active document.  

In contrast to dialog boxes, tool windows keep visible on the user interface as 
long as they are switched on. That gives you access to the settings in the tool 
windows at any time. 

 
Which tool windows are shown by default depends on the layout you have 
chosen. You can, naturally, at any time, make specific tool windows appear and 
disappear manually. To do so, use the View > Tool Windows command.  

Position of the tool windows 
The user interface is to a large degree configurable. For this reason, tool 
windows can be docked, freely positioned, or integrated in document groups. 

Tool windows can be docked to the left or right of the document window, or 
below it. To save space, several tool windows may lie on top of each other. They 
are then arranged as tabs. In this case, activate the required tool window by 
clicking the title of the corresponding tab below the window. 

 
You can only position tool windows as you wish when you are in the expert 
mode. 

You can at any time float a tool window. The tool window then behaves exactly 
the way a dialog box does. To release a tool window from its docked position, 
click on its header with your left mouse button. Then, while keeping the left 
mouse button depressed, drag the tool window to wherever you want it. 

Tool windows and their positions are saved together with the layout and are 
available at the same position the next time you start your software. Resetting 
the layout using the View > Layout > Reset Current Layout command will have 
the result that only the tool windows that are defined by default will be displayed. 

 Button with a cross 

What is a tool window? 

Showing and hiding  
tool windows 

Docked tool windows 

Freely positioned 
 tool windows  

Saving the tool 
window's position 
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Buttons in the header 
In the header of every tool window, you will find the three buttons Help, Auto 
Hide and Close. 

 
Click the Help button to open the online help for the tool window. 
Click the Auto Hide button to minimize the tool window. 
Click the Close button to hide the tool window. You can make it reappear at any 
time, for example, with the View > Tool Windows command. 

Context menu of the header 
To open a context menu, rightclick a tool window's header. The context menu 
can contain the Auto Hide and Transparency commands. 

Additionally, the context menu contains a list of all of the tool windows that are 
available. Every tool window is identified by its own icon. The icons of the 
currently displayed tool windows will appear clicked. You can recognize this 
status by the icon's background color.  
Use this list to make tool windows appear.  
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2.5. Working with documents 
You can choose from a number of possibilities when you want to open, save, or 
close documents. As a rule, these documents will be images. In addition, your 
software supports some other document types. You will find a list of supported 
documents in the online help. 

Saving documents 
You should always save important documents immediately following their 
acquisition. You can recognize documents that have not been saved by the star 
icon after the document's name. 

There are a number of ways in which you can save documents.  

1. To save a single document, activate the document in the document group 
and use the File > Save As... command.  

2. Use the Documents tool window.  
Select the desired document and use the Save command in the context 
menu. For the selection of documents, the standard MS-Windows 
conventions for Multiple Selection are valid.  

3. Use the Gallery tool window. 
Select the desired document and use the Save command in the context 
menu. For the selection of documents, the standard MS-Windows 
conventions for Multiple Selection are valid. 

4. Save your documents in a database. That enables you to store all manner of 
data that belongs together, in one location. Search and filter functions make 
it quick and easy to locate saved documents. Detailed information on 
inserting documents into a database can be found in the online help. 

1. When you exit the program, all of the data that has not yet been saved will be 
listed in the Unsaved Documents dialog box. This gives you the chance to 
decide which document you still want to save. 

2. With some acquisition processes, the acquired images will be automatically 
saved after the acquisition has finished. You will find an overview of the 
acquisition processes that are supported in the online help.  

Autosave and close 
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3. You can also configure your software in such a way that all images are saved 
automatically after image acquisition. To do so, use the Acquisition Settings 
> Saving dialog box.  

Here, you can also configure your software in such a way that all images are 
automatically saved in a database after the image acquisition. 

Closing documents  
There are a number of ways in which you can close documents.  

1. Use the Documents tool window.  
Select the desired document and use the Close command in the context 
menu. For the selection of documents, the standard MS-Windows 
conventions for Multiple Selection are valid.  

2. To close a single document, activate the document in the document group 
and use the File > Close command. Alternatively, you can click the button 
with the cross . You will find this button on the top right in the document 
group. 

3. Use the Gallery tool window. 
Select the desired document and use the Close command in the context 
menu. For the selection of documents, the standard MS-Windows 
conventions for Multiple Selection are valid. 

To close all loaded documents use the Close All command. You will find this 
command in the File menu, and in both the Documents and the Gallery tool 
window's context menu. 

To close a document immediately without a query, close it with the [Shift] key 
depressed. Data you have not saved will be lost. 

Opening documents 
There are a number of ways in which you can open or load documents.  

1. Use the File > Open... command. 

2. Use the File Explorer tool window.  
To load a single image, doubleclick on the image file in the File Explorer tool 
window. 
To load several images simultaneously, select the images and with the left 
mouse button depressed, drag them into the document group. For the 
selection of images the standard MS-Windows conventions for Multiple 
Selection are valid.  

3. Drag the document you want, directly out of the MS-Windows Explorer, onto 
your software's document group. 

4. Use the Database > Load Documents command to load documents from the 
database into your software. Further information is available in the online 
help. 

If you want to get used to your software, then sometimes any image suffices to 
try out a function.  
Press [Ctrl + Shift + Alt + T] to generate a color test image.  
With the [Ctrl + Alt + T] shortcut, you can generate a test image that is made up 
of 256 gray values. 

During the installation of your software some sample images have been installed, 
too. Regarding the information as to where the example images are located, 
please refer to the online help. 

Closing all documents 

Closing a document 
immediately 

Generating a 
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Activating documents in the document group 
There are several ways to activate one of the documents that has been loaded 
into the document group and thus display it on your monitor.  

1. Use the Documents tool window. Click the desired document there. 

2. Use the Gallery tool window. Click the desired document there. 

3. Click the title of the desired document in the document group. 

4. To open a list with all currently loaded documents, use the [Ctrl + Tab] 
shortcut. Leftclick the document that you want to have displayed on your 
monitor.  

5. Use the keyboard shortcut [Ctrl + F6] respectively [Ctrl + Shift + F6], to have 
the next document in the document group displayed. With this keyboard 
shortcut you can display all of the loaded documents one after the other.  

6. In the Window menu you will find a list of all of the documents that have been 
loaded. Select the document you want from this list. 

Please note that in the Database layout the document group will not be shown. 
Select one of the other layouts, e.g., the "Processing" layout, to have the 
document group displayed.  

00143 
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3. Configuring the system 
3.1. Overview - System configuration 

After successfully installing your software you will need to first configure your 
image analysis system, then calibrate it. Only when you have done this will you 
have made the preparations that are necessary to ensure that you will be able to 
acquire high quality images that are correctly calibrated. When you work with a 
motorized microscope, you will also need to configure the existing hardware, to 
enable the program to control the motorized parts of your microscope. 

Process flow of the configuration 
To set up your software, the following steps will be necessary: 

Specifying which hardware is available 

 
Configuring the interfaces 

 
Configuring the specified hardware 

 
Calibrating the system 

 

Your software needs to know which hardware components your microscope is 
equipped with. Only these hardware components can be configured and 
subsequently controlled by the software. In the Acquire > Devices > Device List 
dialog box, you select the hardware components that are available on your 
microscope. 
Further information on this dialog box is available in the online help. 

Use the Acquire > Devices > Interfaces command to configure the interface 
between your microscope or other motorized components, and the PC on which 
your software runs. 
Further information on this dialog box is available in the online help. 

When all of the hardware components have been registered with your software 
and have been configured, the functioning of the system is already ensured. 
However, it's only really easy to work with the system and to acquire top quality 
images, when you have calibrated your software. The detailed information that 
helps you to make optimal acquisitions, will then be available. 
Your software offers a wizard that will help you while you go through the 
individual calibration processes. Use the Acquire > Calibrations... command to 
start the software wizard.  
Further information on this dialog box is available in the online help. 

Notes on the system configuration 
You will only need to completely configure and calibrate your system anew when 
you have installed the software on your PC for the first time, and then start it. 
When you later change the way your microscope is equipped, you will only need 
to change the configuration of certain hardware components, and possibly also 
recalibrate them. 

To be able to configure the system, you have to be logged in to your software 
with administrator or power user rights. If you have installed the software yourself 
you will automatically have been assigned Administrator rights.  

Why do you have to 
configure the system? 

Specifying which 
hardware is available 

Configuring the 
interfaces 

Configuring the 
specified hardware 

Calibrating the system 

When do you have to 
configure the system? 

Necessary user rights 
for the system 
configuration 
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In contrast, other users who also wish to work with the software will only have 
user rights as a Standard User. With these rights, the system configuration 
cannot be changed or viewed, i.e., the Device List and Device Settings dialog 
boxes cannot be opened. 

For this reason, those users who did not themselves install the software, but who 
are to be allowed to view or change the system configuration, have to be 
assigned the necessary user rights. Use the Tools > User Rights... command to 
open the User Rights dialog box. In it, select the required user, then click the 
Properties... button.  

Further information on user rights is available in the online help. 

When you use the MS-Windows Vista operating system: Switch the hibernation 
mode off.  
To do so, click the Start button located at the bottom left of the operating 
system's task bar.  
Use the Control Panel command. 
Open the System and Maintenance > Power Options > Change when the 
computer sleeps window. Here, you can switch off your PC's hibernation mode. 

00159 

3.2. Configuring the system 
In order to acquire correctly calibrated images, the software requires information 
about your camera, the objectives and the microscope camera adaptor's 
magnification. Set up your system with this in mind. 

Your software is installed and the camera is connected to your PC. The camera 
driver is installed in MS-Windows. 

Specifying which hardware is available 
1. Start your software. 

2. Use the Acquire > Devices > Device List... command. 

3. Click the Create New Hardware Configuration  button. 

 The Create New Hardware Configuration dialog box will open. 

4. Enter a name for the new hardware configuration in the Name field. It is a 
good idea to choose a name combining the microscope and camera names, 
for example, "BX51_DP25“.  

 Under this name, you can later reload this hardware configuration in the 
Device Settings dialog box.  

5. Select the Copy current hardware configuration option if you have previously 
chosen your camera and microscope. Otherwise, choose the Empty 
hardware configuration option.  

6. Close the Create New Hardware Configuration dialog box with OK to return 
to the Device List dialog box. 

 You will then find the new hardware configuration entered in the 
Configuration field.  

 Once you have completely set up a new hardware configuration, all 
entries from the Device List will be empty. You can now enter a 
completely new definition for the hardware configuration.  

Define the new hardware configuration in the Device List dialog box. A 
description of the dialog box can be found in the online help. Begin with the 
specifications for the camera and the microscope.  

7. Select your camera (e.g. "DP25") from the Camera 1 list. 
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operating system's 
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8. Select your microscope (e.g. "BX51") from the Frame list. If your microscope 
isn't listed, select the Manual Microscope entry. 

 Once you have chosen a microscope, the options in the Device List 
dialog box change. For some microscopes there are default settings . 

Examples of default settings: 

 For the manual microscope BX51, the Manual Nosepiece entry from the 
Nosepiece list is preset. 

 For the manual stereo microscope SZX10, the Manual Nosepiece and 
Manual Zoom/Magnification Changer entries are preset. 

9. For some microscopes (such as IX71), you need to choose the port on which 
your camera is mounted (e.g. Side (left)). You find the list to the right of the 
camera list. 

10. All other settings, such as nosepiece, observation filter wheel, shutter and 
condensor are appropriately preset, independent of your microscope. Check 
your settings and, if necessary, adjust them to suit your microscope 
equipment. 

11. Close the Device List dialog box with OK. 

 Your hardware configuration will be automatically saved.  

 You can return to the default configuration whenever you want to. To do 
so, use the Acquire > Devices > Device Settings... command. Select the 
Default entry in the Configuration list. 

 As soon as you close the Device List dialog box, your software tries to 
create a connection to the specified devices. You can see whether the 
devices are able to be successfully controlled in the Acquire > Devices > 
Device Settings device box. 

Configuring the specified hardware 
1. Use the Acquire > Devices > Device Settings... command. 

 In the tree view on the left side, you can find all hardware components 
that you have chosen in the device list. 

2. Select the Lightpath entry in the Sort by list. 

3. In the tree view on the left-hand side, expand the Camera > <camera name> 
entry (e.g. "DP25“). 

4. Select the Camera Adapter entry.  

5. Select your camera adapter's magnification on the right-hand side of the 
Magnification list. The magnification is imprinted on your camera adapter. 
Common values are "1.00" or "0.63". 

6. In the tree structure, select the General > Manual Nosepiece entry (if you 
have a manual microscope), or General > Nosepiece <Name of the 
nosepiece> (if you have a motorized microscope). 

 On the right hand side of the dialog box, the current configuration of the 
nosepiece will be displayed. When you configure the software for the first 
time, the fields for the details referring to your objectives will be empty. 

7. Choose the objectives which are currently fitted to the nosepiece from the 
right-hand side of the Magnification lists. Start with the smallest magnification 
and increase up through the higher magnifications. You can read the 
magnification off of the objective.  

8. Choose each corresponding objective from the Objective Type list. The type 
is written on the objective.  

Initializing your devices 

Configuring your 
camera 
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 In the Description field, a description of the objective will be suggested. 
You may change the description of the objective in the Description field, 
if you wish.  

9. If the objectives don't use air as their refraction medium, select the immersion 
medium from the Refraction Index list. In this case, you find an appropriate 
label on the objective. 

10. Select the General > <Name of the mirror turret> entry in the tree view. 

11. Make a selection for every position, whether it is occupied or not. For 
occupied positions, either select a filter or fluorescence cube being used from 
the Filter list, or enter the name of your filter module.  

12. Select the Free entry for positions that have been purposely left free to keep 
the light path free of optical elements.  
For example, where the mirror turret is concerned, it is especially important 
that one position is kept free, in order not to impede the light path for the 
transmitted light microscopy.  

13. Close the Device Settings dialog box with OK. 

 In certain cases, you receive a message telling you to check the 
calibrations. You can perform calibration now or later. 

14. To have this toolbar displayed, use the View > Toolbars > Microscope 
Control command.  

 The Microscope Control toolbar contains buttons with all of your 
objectives with correct color codes.  

 For stereo microscopes or inverted microscopes, you find the zoom 
factors in the list to the right of the objectives. 
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4. Acquiring images  
4.1. Acquiring a single image 

You can use your software to acquire high resolution images in a very short 
period of time. For your first acquisition you should carry out these instructions 
step for step. Then, when you later make other acquisitions, you will notice that 
for similar types of sample many of the settings you made for the first acquisition 
can be adopted without change. 

Acquiring a single image 
1. Switch to the "Acquisition" layout. To do this, use, e.g., the View > Layout > 

Acquisition command. 

 You can find the Microscope Control (1) toolbar at the upper edge of the 
user interface, right below the menu bar. To the right of the document 
group, you can find the Camera Control tool window (2). 

 
2. On the Microscope Control toolbar, click the button with the objective that 

you use for the image acquisition. 

3. In the Camera Control tool window, click the Live  button. 

 The live-image (3) will now be shown in the document group. 

4. Go to the required specimen position in the live-image. 

5. Bring the sample into focus. The Focus Indicator toolbar is there for you to 
use when you are focusing on your sample.  

6. Check the color reproduction. If necessary, carry out a white balance. 

7. Check the exposure time. You can either use the automatic exposure time 
function, or enter the exposure time manually. 

8. Select the resolution you want. 

9. In the Camera Control tool window, click the Snapshot button  .  

 The acquired image will be shown in the document group.  

10. Use the File > Save As... command to save the image. Use the 
recommended TIF file format. 
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4.2. Acquiring movies and time stacks 
With your software you can acquire movies and time stacks. 

Acquire a movie 
You can use your software to record a movie. When you do this, your camera will 
acquire as many images as it can within an arbitrary period of time. The movie 
will be saved as a file in the AVI format. You can use your software to play it 
back. 

1. Switch to the "Acquisition" layout. To do this, use, e.g., the View > Layout > 
Acquisition command. 

2. On the Microscope Control toolbar, click the button with the objective that 
you want to use for the movie acquisition. 

3. In the Camera Control tool window's toolbar, click the Acquisition Settings 

 button.  

 The Acquisition Settings dialog box will open. 

4. Select the Saving > Movie entry in the tree structure. 

5. You have to decide how a movie is to be saved after the acquisition. Select 
the Filesystem entry in the Automatic save > Destination list to automatically 
save the movies you have acquired. 

 The Base field located in the Directory group shows the directory that will 
currently be used when your movies are automatically saved.  

6. Click the [...] button next to the Base field to alter the directory.  

 The AVI file format is preset in the File type list. This is a fixed setting 
that cannot be changed.  

7. Click the Options... button if you want to compress the AVI file in order to 
reduce the movie's file size. 

8. From the Compression list, select the M-JPEG entry and confirm with OK. 

Please note: Compressing the movie is only possible if the selected 
compression method (codec) has already been installed on your PC. If the 
compression method has not been installed the AVI file will be saved 
uncompressed. 
The selected compression method must also be available on the PC that 
is used for playing back the AVI. Otherwise the quality of the AVI may be 
considerably worse when the AVI is played back. 

9. Close the Acquisition Settings dialog box with OK.  

10. Switch to the live mode, and select the optimal settings for movie recording, 
in the Camera Control tool window. Pay special attention to setting the 
correct exposure time.  

 This exposure time will not be changed during the movie recording. 

11. Find the segment of the sample that interests you and focus on it. 

12. Select the Movie recording check box (1). The check box can be found below 
the Live button in the Camera Control tool window. 
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 The Snap button will be replaced by the Movie button. 

13. Click the Movie button to start the movie recording. 

 The live-image will be shown and the recording of the movie will start 
immediately.  

 In the status bar a progress indicator is displayed. At the left of the slash 
the number of already acquired images will be indicated. At the right of 
the slash an estimation of the maximum possible number of images will 
be shown. This number depends on your camera's image size and 
cannot exceed 2GB. 
 

 

 This icon  on the Movie button will indicate that a movie is being 
recorded at the moment. 

14. Click the Movie button again to end the movie recording. 

 The first image of the movie will be displayed. 

 The navigation bar for time stacks will be shown in the document group. 
Use this navigation bar to play the movie. 

 The software will remain in the "Movie recording" mode until you clear 
the Movie recording check box once more. 

Acquiring a time stack 
In a time stack all frames have been acquired at different points of time. With a 
time stack you can document the way the position on the sample changes with 
time. To begin with, for the acquisition of a time stack make the same settings in 
the Camera Control tool window as you do for the acquisition of a snapshot. 
Additionally, in the Process Manager tool window, you have to define the time 
sequence in which the images are to be acquired.  

You want to acquire a time stack over a period of 10 seconds. One image is to 
be acquired every second.  

1. Switch to the "Acquisition" layout. To do this, use, e.g., the View > Layout > 
Acquisition command. 

2. On the Microscope Control toolbar, click the button with the objective that 
you want to use for the image acquisition. 

3. Switch to the live mode, and select the optimal settings for your acquisition, 
in the Camera Control tool window. Pay special attention to setting the 
correct exposure time. This exposure time will be used for all of the frames in 
the time stack. 

4. Choose the resolution you want for the time stack's frames, from the 
Resolution > Snap/Process list. 

5. Find the segment of the sample that interests you and focus on it. 

6. Activate the Process Manager tool window.  

7. Select the Automatic Processes option. 
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8. Click the Time Lapse  button.  

 The button will appear clicked. You can recognize this status by the 
button's colored background.  

 The [ t ] group will be automatically displayed in the tool window. 

9. Should another acquisition process be active, e.g., Multicolor, click the button 
to switch off the acquisition process. 

 The group with the various acquisition processes should now look like 
this: 

 
10. Clear the check boxes Delay and As fast as possible. 

11. Specify the time that the complete acquisition is to take, e.g., 10 seconds. 
Enter the value "00000:00:10" (for 10 seconds) in the Recording time field. 
You can directly edit every number in the field. To do so, simply click in front 
of the number you want to edit. 

12. Click the button with the lock  located to the right of the field, to specify 
that the acquisition time is no longer to be changed.  

13. Specify how many frames are to be acquired.  
Enter e.g., 10 in the Cycles field. 

 The Interval field will be updated. It shows you the time that will elapse 
between two consecutive frames. 

 

14. Click the Start  button. 

 The acquisition of the time stack will start immediately.  

 The Start Process button changes into the Pause  button. A click on 
this button will interrupt the acquisition process.  

 The Stop  button will become active. A click on this button will stop 
the acquisition process. The images of the time stack acquired until this 
moment will be preserved. 

 At the bottom left, in the status bar, the progress bar will appear. It 
informs you about the number of images that are still to be acquired.  

 The acquisition has been completed when you can once more see the 

Start  button in the Process Manager tool window, and the progress 
bar has been faded out.  

 You will see the time stack you've acquired in the image window. Use the 
navigation bar located in the image window to view the time stack. 
Further information on the navigation bar is available in the online help. 

 The time stack that has been acquired will be automatically saved. The 
storage directory is shown in the Acquisition Settings > Saving > Process 
Manager dialog box. The preset file format is VSI. 

Tip: When other programs are running on your PC, for instance a virus scanning 
program, it can interfere with the performance when a time stack is being 
acquired. 
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4.3. Acquiring a Z-stack 
A Z-stack contains frames acquired at different focus positions. That is to say, 
the microscope stage was located in a different Z-position for the acquisition of 
each frame.  

Tip: You can only use the Z-Stack acquisition process when your stage is 
equipped with a motorized Z-drive.  

Acquiring a Z-stack 
Example: You want to acquire a Z-stack. The sample is approximately 50 µm 
thick. The Z-distance between two frames is to be 2 µm.  

 
1. Switch to the "Acquisition" layout. To do this, use, e.g., the View > Layout > 

Acquisition command. 

2. On the Microscope Control toolbar, click the button with the objective that 
you want to use for the image acquisition. 

3. Switch to the live mode, and select the optimal settings for your acquisition, 
in the Camera Control tool window. Pay special attention to setting the 
correct exposure time. This exposure time will be used for all of the frames in 
the Z-stack. 

4. Search out the required position in the sample. 

5. Activate the Process Manager tool window.  

6. Select the Automatic Processes option. 

7. Click the Z-Stack  button.  

 The button will appear clicked. You can recognize this status by the 
button's colored background.  

 The [ Z ] group will be automatically displayed in the tool window. 

8. Select the Range entry in the Define list. 

9. Enter the Z-range you want, in the Range field. In this example, enter a little 
more than the sample's thickness (= 50 µm), e.g., the value 60.  

10. In the Step Size field, enter the required Z-distance, e.g., the value 2, for a Z-
distance of 2 µm. The value you enter should roughly correspond to your 
objective's depth of focus. 

 In the Z-Slices field you will then be shown how many frames are to be 
acquired. In this example, 31 frames will be acquired. 

9. Find the segment of the sample that interests you and focus on it. To do this, 
use the arrow buttons in the [ Z ] group. The buttons with a double arrow 
move the stage in larger steps.  

10. Click the Start  button. 

 Your software now moves the Z-drive of the microscope stage to the 
start position. The starting positions lies half of the Z-range deeper than 
the stage's current Z-position. 

 The acquisition of the Z-stack will begin as soon as the starting position 
has been reached. The microscope stage moves upwards step by step 
and acquires an image at each new Z-position. 
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 The Start Process button changes into the Pause  button. A click on 
this button will interrupt the acquisition process.  

 The Stop  button will become active. A click on this button will stop 
the acquisition process. The Z-stack as acquired up till then, will be 
preserved. 

 At the bottom left, in the status bar, the progress bar will appear. It 
informs you about the number of images that are still to be acquired.  

 The acquisition has been completed when you can once more see the 

Start  button in the Process Manager tool window, and the progress 
bar has been faded out.  

 You can see the acquired Z-stack in the image window. Use the 
navigation bar located in the image window to view the Z-stack. Further 
information on the navigation bar is available in the online help. 

 The Z-stack that has been acquired will be automatically saved. You can 
set the storage directory in the Acquisition Settings > Saving > Process 
Manager dialog box. The preset file format is VSI. 

Tip: When other programs are running in the background on your PC, for 
instance a virus scanning program, it can interfere with the performance when a 
Z-stack is being acquired. 
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4.4. Acquiring an EFI image 
EFI is the abbreviation for "Extended Focus Image". By using the "EFI" 
acquisition process you can acquire images with your microscope which have 
practically unlimited depth of focus. To do this, EFI uses a series of differently 
focused separate images ("Focus series") to calculate a resulting image ("EFI 
image"), that is focused in all of its parts. 

 
The illustration shows left, a number of frames that were acquired at different Z-
positions. In each of these frames there are only a few image segments that are 
displayed sharply focused. These segments are shown in color. These sharply 
focused image segments will be assembled into the EFI image (right). 

Your software offers you several ways of creating an EFI-image.  

 Acquiring an EFI image without a motorized Z-drive 
 Acquiring an EFI image with a motorized Z-drive 

What is EFI? 

Creating an EFI image 
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Acquiring an EFI image without a motorized Z-drive  
You have a thick section in the transmitted light mode, or a sample with a very 
rough surface in the reflected light mode, e.g., with holes, grooves, bumps peaks 
or slanting planes. In the image it's only possible to bring one layer of the section, 
resp. only part of the surface, sharply into focus, higher-lying or deeper-lying 
areas are outside the depth of focus range. Acquire a Z-stack through the 
complete thickness resp. height, of the sample, and have the EFI image 
calculated for you.  

In this case you can use the manual Instant EFI acquisition process, to acquire a 
sharply focused image of all of the sample.  

Tip: You can use the Instant EFI acquisition process with every microscope. 
When your microscope stage is equipped with a motorized Z-drive, use the Z-
Stack acquisition process to acquire an EFI image.  

1. Use the View > Tool Windows > Process Manager command to make the 
Process Manager tool window appear. 

2. Select the Manual Processes option. 

3. Click the Instant EFI  button. 

 The button will appear clicked. You can recognize this status by the 
button's colored background.  

 The Instant EFI group will be automatically displayed in the tool window. 

4. From the Algorithm list, select the Reflected light entry, when you use your 
light, or stereo microscope in the reflected light mode.  

5. If you work with a stereo microscope, select the Automatic frame alignment 
check box.  
If you don't work with a stereo microscope, clear the Automatic frame 
alignment check box. 

6. Use the View > Tool Windows > Camera Control command to make the 
Camera Control tool window appear. 

7. In the Camera Control tool window, click the Live  button. 

8. Move the microscope focus to the Z-position where either the lowest or the 
highest place on the object is only just no longer sharply focused. Use the 
live-mode for a visual control. 

9. Check the exposure time, and correct it if necessary. When the InstantEFI 
acquisition process has been started, the exposure time will be kept constant 
during the whole of the acquisition. 

10. In the Process Manager tool window, click the Start  button. 

 The live-image in the document group will divide itself into 3 images. On 
the bottom right, you'll still see the live-image (3). On the bottom left, 
you'll see the sharpness map (2). The large image above them is the 
composite resulting image 1. The 3 images will be continually updated. 
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11. Use your microscope's Z-drive to move your stage slowly through the height 

range of the sample's surface.  

 The software will acquire images at the various focal planes, then it will 
set them together. While this is being done, the camera will acquire the 
images as quickly as possible. The sharpness value of individual pixels 
will be calculated for every image. If the sharpness values are higher 
than in the previous images, the pixels in the composite EFI image will 
be adopted. The EFI image contains the pixels with the highest 
sharpness values from all of the images acquired up till then. 

 The sharpness map at the bottom left will show you which image areas 
will be sharply reproduced in the EFI image. The brighter a pixel is in the 
sharpness map, the higher is its sharpness value in the EFI image.  

 Once the acquisition process has been started, the sharpness map 
should only be bright at the deepest, resp. highest, parts of the sample, 
the rest of the map is dark. 

12. Focus on the sample slowly once through all the focal planes.  
After each change of the focus position, wait until you see that further areas 
become brighter in the sharpness map.  

 As the process continues, more and more areas in the sharpness map 
should become brighter. At the same time the EFI image will also get 
better and better. 

13. Check the EFI image and the sharpness map. Are all areas of the image now 
sharp? Are there any areas in the sharpness map that are still dark?  
Focus on these areas and have additional images calculated into the EFI 
image. Continue acquiring additional images until the whole sample has 
been sharply reproduced. 

14. In the Process Manager tool window, click the Stop  button. 

 The resulting image is a standard image. 

 The EFI image will be automatically saved. You can set the storage 
directory in the Acquisition Settings > Saving > Process Manager dialog 
box. The preset file format is VSI. 

15. In the Camera Control tool window, click the Live  button again to 
release it. 



Acquiring images

 

27 

Acquiring an EFI image with a motorized Z-drive 
You have a thick section in the transmitted light mode, or a sample with a very 
rough surface in the reflected light mode, e.g., with holes, grooves, bumps peaks 
or slanting planes. In the image it's only possible to bring one layer of the section, 
resp. only part of the surface, sharply into focus, higher-lying or deeper-lying 
areas are outside the depth of focus range. Acquire a Z-stack through the 
complete thickness resp. height, of the sample, and have the EFI image 
calculated for you.  

In this case you can use the automatic Z-stack acquisition process, to acquire a 
sharply focused image of all of the sample.  

You can only use the Z-Stack acquisition process when your stage is equipped 
with a motorized Z-drive.  

1. Activate the Process Manager tool window.  

2. To open the Acquisition Settings dialog box, click the Acquisition Settings 

 button in the tool window's toolbar. 

3. Select the Acquisition > Automatic EFI entry in the tree view. 

4. In the Algorithm list, select the Transmitted light (exp) entry, if you're working 
in the transmitted light mode, and the Reflected light entry if you're working in 
the reflected light mode. 

5. Select the Automatic frame shift check box when you're working with a stereo 
microscope and acquiring the sample at a viewing angle.  
Otherwise, clear this check box. 

6. Close the Acquisition Settings dialog box with OK. 

1. Carry out all the microscope settings. 

2. In the Microscope Control toolbar, click the button corresponding to the 
objective you've set. 

3. Activate the Camera Control tool window.  

4. Switch to the live mode.  

5. Optimize the exposure time. The exposure time will be kept constant during 
the acquisition of the Z-stack. 

6. Click the Autofocus  button in the Camera Control tool window's toolbar 
to focus. 

1. Activate the Process Manager tool window. 

2. Select the Z-Stack  acquisition process. 

3. Select the Top & Bottom entry in the Define list. 

4. Use the arrow buttons in the [ Z ] group to move your stage to the Z-position 
at which the lowest-lying position on the sample is sharply focused.  
The arrow buttons move the stage by steps of 2 µm resp. of 20 µm. 

 The stage's current position will be shown to you in the Pos. field. 

5. Click the top Set button to define the starting position for the Z-stack 
acquisition. 

 The current Z-position will be adopted in the Start field. 
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6. Use the arrow buttons in the [ Z ] group to move your stage to the Z-position 
at which the highest-lying position on the sample is sharply focused.  

7. Click the bottom Set button to define the position at which the Z-stack 
acquisition is to end. 

 The current Z-position will be adopted in the Start field. 

8. In the Step Size field, enter the distance between two frames in the Z-stack. 
This Z-distance should be small enough to ensure that no positions on the 
sample between two images remain blurred. The higher your objective's 
Numerical Aperture is, the smaller the Z-spacing should be.  

9. Use the [Enterl] key to confirm the Z-distance that you've set.  

 The number of images in the stack will be automatically calculated on the 
basis of the Start and End values, and the Z-distance. 

1. Select the Extended Focal Imaging (1) check box. You find the check box at 
the bottom of the [ Z ] group located in the Process Manager tool window. 

 
2. Finish the live mode. 

3. Click the Start  button. 

 The EFI acquisition begins immediately. 

 The acquisition will begin. After the acquisition has been completed the 
EFI image will be shown in the document group. This image was 
calculated from the variously focused separate images.  

00372 
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4.5. Creating stitched images 
If you acquire a stitched image, move the stage in a way that different, adjoining 
parts of the sample are shown. All of the images that are acquired are combined, 
just like a puzzle, into a stitched image. The stitched image will display a large 
part of the sample in a higher X/Y-resolution than would be possible with a 
simple snapshot.  

 
The illustration shows left, four individual images. On the right, you see the 
stitched image made up from the four images. 

Your software offers you several ways of creating a stitched image.  

 Acquiring a stitched image without a motorized XY-stage (Manual MIA) 

 Acquiring a stitched image with a motorized XY-stage (XY-Positions / 
MIA) 

 Acquiring a stitched image with extended depth of focus 

 Automatically acquiring several stitched images 

 Combining individual images into a stitched image 

Acquiring a stitched image without a motorized XY-stage 
(Manual MIA) 
You want to acquire an image of a large sample area. Use the Manual MIA 
acquisition process, to acquire several individual images of adjoining positions on 
the sample, and to have them combined into a stitched image. MIA stands for 
Multiple Image Alignment. 

The camera is aligned parallel to the XY-stage. The angle between camera and 
stage should be smaller than 1°. 

1. Switch to the "Acquisition" layout. To do this, use, e.g., the View > Layout > 
Acquisition command. 

2. On the Microscope Control toolbar, click the button with the objective that 
you want to use for the acquisition of the stitched image. 

3. Switch to the live mode, and select the optimal settings for your acquisition, 
in the Camera Control tool window. Pay special attention to setting the 
correct exposure time. This exposure time will be used for all of the stitched 
image's individual images. 

4. Find the position on the sample at which you want to start acquiring the 
stitched image. 

5. Finish the live mode. 

6. Activate the Process Manager tool window.  

7. Select the Manual Processes option. 

8. Click the Manual MIA  button.  

What is a stitched 
image? 

Creating a 
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 The button will appear clicked. You can recognize this status by the 
button's colored background.  

 The Manual MIA group will be automatically displayed in the tool window. 

 Should the Instant EFI acquisition process have been active, it will be 
automatically switched off. You can, however, use images with extended 
depth of focus for the stitched image. To do this, before you acquire each 

of the individual images, click the Instant EFI  button, located in the 
Manual MIA group. 

9. Make quite certain that the Auto Align button appears clicked. It should then 

look like this: . 

 Then, your software will search for the same image structures in 
neighboring individual images. The stitched image will be put together in 
such a way that image areas that are the same will be superimposed. 

10. Click the Start  button. 

 Your software switches into the live mode. 

11. Bring the sample into focus.  

12. Click on one of the arrow buttons to set the side of the current image at 

which the next image is to be arranged. For example, click this button , if 
the next image is to be laid to the right of the current image. 

 Your system now acquires an image at the current position on the 
sample. In the image window you now see on the left (1) the acquired 
image, and on the right (2) the live-image is displayed. 
 

 
 
Since you haven't moved the sample, the live-image still shows the 
current sample position, too, which means that you now see the current 
image twice.  
The two images overlap. Since the live-image is shown transparent, you 
see both images in the overlap area simultaneously.  

13. Make a note of a significant structure on the live-image's right border. You 
will find the same sample structure in the overlap area. On the illustration, a 
significant structure has been indicated by a circle. 

14. Now move the stage very slowly to make the structure on the live-image 
move to the left. Keep moving the stage until the image structures in the 
overlap area lie as exactly over each other as possible. The image structures 
need not lie precisely over each other, since your software will match the 
individual images with each other. 

 In the overlap area (3), the same image segments are shown now. This 
enables your software to seamlessly combine the two images.  

Selecting the 
acquisition parameters 

Acquiring a  
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 You can reverse the direction in which your stage moves, in the Device 
Settings > Stage dialog box. Depending on how you can best orient 
yourself, the live-image will then move to the left or to the right, when you 
move your stage to the right. 

15. Check whether both images have been correctly combined. Otherwise you 

can undo the last step by using the Undo last frame  button. You can then 
move the stage again, and match the structures better. 

 During the acquisition, you can change the current stitched image's 
zoom factor, e.g., to see certain parts in the overlap area better. You will 
find an overview on the possibilities of changing an image's zoom factor 
in the online help. 

16. Define your way through the sample, with the arrow buttons, and follow that 
with the stage.  
In this manner, you can display a sample in any form you like in the stitched 
image. The illustration shows a stitched image that is made up of 9 individual 
images, and the stage path. 
 

 

17. Click the Stop  button when you want to end the acquisition of the 
stitched image.  

 You see the completed stitched image (4) in the image window.  
Since the individual images can lie a little askew of each other, the 
stitched image isn't as a rule, rectangular, but contains empty areas on 
its borders (5). These areas will, as a rule, be cut off in the stitched 
image.  
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 The stitched image will, by default, be automatically saved. The storage 
directory is shown in the Acquisition Settings > Saving > Process 
Manager dialog box. The preset file format is VSI. 

 By default, in the overlap area, the intensity values of two adjoining 
individual images will be matched with each other, to make the image's 
overall impression homogeneous. 

 Stitched images are calibrated. This means that you can measure 
distances and objects on a stitched image.  

Acquiring a stitched image with a motorized XY-stage  
(XY-Positions / MIA) 

 
 

You want to acquire an image of a large sample area. Use the automatic XY-
Positions / MIA acquisition process, to scan a rectangular area of the sample and 
to have adjoining images combined into one stitched image. MIA stands for 
Multiple Image Alignment. 

 
You can only use the XY-Positions/ MIA acquisition process when your 
microscope is equipped with a motorized XY-stage.  

 The stage has been set up and initialized, i.e. its stage limits have been 
defined. 

 The camera is aligned parallel to the XY-stage. The angle between 
camera and stage should be smaller than 1°. 

 The shading correction has been set up. 
1. Switch to the "Acquisition" layout. To do this, use, e.g., the View > Layout > 

Acquisition command. 

2. On the Microscope Control toolbar, click the button with the objective that 
you want to use for the acquisition of the stitched image. 

3. Activate the Process Manager tool window.  

4. Select the Automatic Processes option. 

5. Click the XY-Positions / MIA  button.  

 The button will appear clicked. You can recognize this status by the 
button's colored background.  

 The XY group will be automatically displayed in the tool window. 

Properties of the 
stitched image 

Task 

Prerequisite 

Selecting objective 

Selecting the 
acquisition process 



Acquiring images

 

33 

6. If your microscope is equipped with a motorized Z-drive, you can switch on a 
software autofocus.  
In the Process Manager tool window, click the Software Autofocus button. 

 

 The Software Autofocus group will be automatically displayed in the tool 
window. 

7. In the Software Autofocus group, select the Multiposition / MIA check box.  

8. If the sample surface is not plane or if it is inclined to the objective, choose 
the Every MIA frame option. Now, the software autofocus will be performed 
before every image acquisition. 

9. In the Process Manager tool window, click this button .  

 The Stage Navigator tool window will be shown. When you have 
acquired an overview image of your sample, you will see this area of the 
image in the stage navigator's image segment. 

10. Set the magnification for the image segment in the Stage Navigator tool 
window. To do this, use the zoom buttons at the bottom left of the tool 
window (2). 
The current stage position will be shown by a yellow rectangle in the image 
segment (1). You should choose a magnification that enables you to see this 
rectangle clearly. 
 

 

 Further information on the Stage Navigator tool window is available in 
the online help. 

11. In the Process Manager tool window, click this button .  

 The system will automatically switch into the live mode. 

 The Define MIA Scanning Area dialog box will open. 

12. Move the XY-stage to the top left-hand corner of the MIA scan area you want 
(3). 

13. Focus, then select the optimal settings for your acquisition in the Camera 
Control tool window. Pay special attention to setting the correct exposure 
time. This exposure time will be used for all of the stitched image's individual 
images. 

14. Confirm the starting position in the Define MIA Scanning Area dialog box, 
with OK. 

Using the  
software autofocus 
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15. Move the XY-stage to the bottom right-hand corner of the MIA scan area (4). 
Confirm this position in the Define MIA Scanning Area dialog box, with OK. 

 In the Stage Navigator tool window, the MIA scan areas that have been 
defined are displayed. Here, you can immediately see how many 
individual images are required for the acquisition of the stitched image, 
when the current magnification is used.  

 

 

16. Click the Start  button. 

 The acquisition begins immediately. The individual images are acquired, 
then immediately assembled. You can watch how the stitched image 
grows, in the image window. 

 The Stop  button will become active. A click on this button will stop 
the acquisition process. The stitched image acquired up till then, will be 
preserved. 

 In the status bar at the bottom left of the user interface, you will find a 
progress bar, the number of images already acquired, and the total 
number of frames (e.g., 3/9). 

 The acquisition has been completed when you can once more see the 

Start  button in the Process Manager tool window, and the progress 
bar has been faded out.  

 You see the completed stitched image, in the image window. The 
individual images won't be saved separately. 

 The stitched image will, by default, be automatically saved. The storage 
directory is shown in the Acquisition Settings > Saving > Process 
Manager dialog box. The preset file format is VSI. 

 
Acquiring a  
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Acquiring a stitched image with extended depth of focus 
The acquisition of a stitched image with extended depth of focus, is both with and 
without, a motorized XY-stage, possible.  

1. Start the Manual MIA  acquisition process.  
 
You will find a step-by-step instruction for doing this further above. 

2. Click the Instant EFI  button, in the Manual MIA group. 

 The Instant EFI acquisition process will start at once. Instead of the live-
image, you now see the EFI image.  

3. Now move your microscope's Z-drive slowly and change the focusing of the 
image. Observe how the EFI image builds itself up. 

 For each image that is acquired, the sharpest image segment is adopted 
in the EFI image.  

4. When all of the image structures are sharply displayed, click one of the 
direction arrows in the Manual MIA group, to continue with the acquisition of 
the stitched image.  

Tip: You now see the live-image with the last focus settings. That means that 
normally, the live-image won't be in focus. 

5. Bring the image into focus. 

6. Repeat the last steps for each of the stitched image's individual images for 
which you want to use the Instant EFI acquisition process.  

7. Click the Stop  button when you want to end the acquisition of the 
stitched image.  

 You see the completed stitched image, in the image window. 

You can only use the EFI acquisition process when your stage is equipped with a 
motorized Z-drive.  

1. Select the XY-Positions / MIA  acquisition process.  

2. Define an MIA scan area. 
You will find a step-by-step instruction for doing this further above. 

3. Additionally, select the Z-Stack  acquisition process.  

 In the group with the different acquisition processes, two of them are now 
active: 
 

 
4. Define all of the parameters for the Z-stack's acquisition.  

5. In the [ Z ] group, select the Extended Focal Imaging check box.  

6. Click the Start  button, to begin the acquisition of the stitched image. 

 
Without a motorized 

XY-stage 

With a motorized  
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 At each of the MIA scan area's stage positions, a Z-stack will first be 
acquired, then the EFI image calculated from it. The EFI images will be 
combined into a stitched image.  

 When the acquisition process has been completed, you'll see the 
finished stitched image in the image window.  

Automatically acquiring several stitched images 
You can define several MIA scan areas on the sample. When the acquisition has 
started, all of the MIA scan areas will be moved to, one after the other, and a 
stitched image will be acquired at every position. 

1. Select the XY-Positions / MIA  acquisition process.  

2. Define several MIA scan areas. You will find a step-by-step instruction on 
how to define an MIA scan area further above. 
Begin with the area of the sample that is to be scanned first. 

3. In the Process Manager tool window, click this button .  

 The Stage Navigator tool window will be shown. When you have 
acquired an overview image of your sample, you will see this area of the 
image in the stage navigator's image segment. 

 In the Stage Navigator tool window, the MIA scan areas that have been 
defined are displayed. They are numbered serially in the order in which 
they were defined.  

4. Click the Start  button, to begin the acquisition of the stitched image. 

 Each of the MIA scan areas will now be scanned, and the stitched image 
created. The scan areas will be scanned in the order that is predefined 
by the numbering.  

 All of the stitched images will be acquired with the current camera, and 
current acquisition settings.  

 When the acquisition process has been completed, you'll find a stitched 
image for each of the MIA scan areas, in the document group.  
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Combining individual images into a stitched image 
Use the Process > Multiple Image Alignment… menu command to have several 
separate images combined, as with a puzzle, into a stitched image. The 
individual images will be combined in their full X/Y-resolution. The stitched image 
will thus display a large sample segment in a higher X/Y-resolution than would be 
possible with a single acquisition. 

1. Load the images you want to combine, or acquire a suitable set of images.  

 All of the images you want to combine must be of the same image type. 
You can't, e.g., have a gray-value image combined with a true-color 
image.  

 When you acquire the images, number their names sequentially, e.g., 
"Image001", "Image002" and so on. In many cases, the images will then 
already be arranged in the right order in the Multiple Image Alignment 
dialog box.  

2. Open the Gallery tool window. To do this, use, e.g., the View > Tool 
Windows > Gallery command. 

3. Select all of the images you want to combine, in the Gallery tool window. 

4. Use the Process > Multiple Image Alignment... command. This command is 
only active when more than one image of the same image type has been 
selected. 

 The Multiple Image Alignment dialog box will open.  

 The dialog box's stitching area will display a preview of the individual 
images. 

5. If necessary, while keeping your left mouse button depressed, drag on the 
bottom left-hand corner of the dialog window to enlarge it. Alternatively, 
doubleclick the header of the dialog box to enlarge the dialog box to full-
screen size.  

6. Check whether the images' positions are correct. You can change the 
arrangement of the individual images, e.g., by exchanging two images in the 
stitching area by Drag&Drop.  

 

 The illustration shows the stitching area with four individual images.  
On the left, the images 1 and 2 are not in the correct position. Image 1 
(green frame) will therefore be dragged onto image 2 (red frame).  
On the right, you see the stitching area after the two images have been 
interchanged. 

7. When the individual images overlap, select the Correlation option in the 
Output > Alignment list.  
Then, your software will search for the same image structures in neighboring 
individual images. The stitched image will be put together in such a way that 
image areas that are the same will be superimposed. 

8. Click the OK button to carry out the automatic image alignment.  

Acquiring images 

Selecting images 

Assembling images 
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 The Multiple Image Alignment - Manual Align dialog box opens.  

 The stitched image will be displayed. 

9. Check the stitched image on display.  
Use the zoom buttons in the dialog box to zoom in the stitched image in the 
dialog box. 
 

 
10. Should individual images have been incorrectly assembled, you can 

manually shift one or more of them, in respect to one another.  
To do this, click in the image you want to shift, then drag it with your left 
mouse button depressed, in the required direction. 

 The currently selected image will be displayed semi-transparently, to 
make it easier for you to find the point of contact with the neighboring 
image. 

 

 Two images were not correctly aligned with each other. There is a 
misalignment. When the manual alignment has been made, the two 
images fit together seamlessly. 

11. Select the Cut Edges check box, to clip the image in such a way that there 
are no longer any empty areas visible on its borders.  

 In the preview, the image edges that are to be clipped will be displayed 
semi-transparently.  

12. Select the Equalize check box, if the images aren't homogeneously 
illuminated. Then the intensity values of the individual images will be 
matched with one another, which will make the background appear more 
homogeneous.  

13. Click OK. 

 A new image with the name "Image_<consecutive No.>" will be created.  
00383 
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5. Processing images 
5.1. Processing images 

The Process menu offers numerous image processing functions, with which you 
can change an acquired image (e.g., increase the image contrast or the image 
sharpness).  

Processing images 
1. Load the image you want to process, or activate the image in the document 

group. 

 Please note that the Process menu will only be visible when an image 
window is active in the document group. 

2. Use one of the commands in the Process menu, e.g., Process > 
Enhancement > Adjust Intensity... . 

 The image processing dialog box will open. The image processing 
operation that is active will be shown in the dialog boxes header. 

3. Click the small arrow next to the Preview  button to open a list of all of 
the preview functions. Select the Original and Preview entry.  

 This preview function displays the same image segment twice in the 
dialog box. The first one shown is the source image. The second is the 
image that results when the current parameters are used. 

 Most of the image processing operations need one or two of the 
parameters that are shown in the Settings group.  

4. Change the image processing operation's parameters. After every change 
that is made in a parameter, the operation will be immediately applied to the 
source image, and the resulting image will be shown in the preview window. 
Click the Default button, to readopt the preset parameters in the Settings 
group, when the current parameter doesn't make sense to you. 

5. When you have found the optimal parameters, click the OK button to have 
the active image processing operation applied to the image with the active 
parameters. 

 The image processing dialog box will closed. 

 Please note that the image processing operation changes the source 
image. No new image document will be created. You can, however use 
the Edit > Undo command to restore the source image.  

00175 
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6. Measuring images 
6.1. Overview - Measuring images 

Your software offers a wide range of measurement functions. They enable you to 
quickly count objects and measure segments and areas. All the results will be 
saved together with the image and can also be issued as a sheet. 

 
For making measurements, correctly calibrated images are an essential 
prerequisite. Images that you have acquired with your software will have been 
automatically correctly calibrated when you have specified the objective you 
used.  
Should the image not yet have been calibrated, use the Image > Calibrate 
Image... command to carry out a calibration. 

Selecting the measurement environment 
Switch to the "Processing" layout if you want to measure images. You will find 
the Measurement and ROI tool window in the bottom section of this layout. In this 
tool window you have fast access to all measurement functions and settings 
which relate to the measurement. This tool window is at the same time the 
measurement display and contains all of the values that have been measured on 
the active image. 

Tip: If there are two tool windows, one under the other, at the bottom of the user 

interface: Activate the Measurement and ROI tool window, by clicking the  
Measurement and ROI tab's title below the tool window. 

Starting a measurement 
Begin a measurement by selecting the measurement function you want. You will 
find the measurement function in the Measurement and ROI tool window, on the 
Measurement and ROI toolbar, or in the Measure menu.  

As soon as you have clicked a measurement function, your software will 
automatically switch to a measurement mode. In the measurement mode your 
mouse pointer will take on the shape of a cross on the image. You can make as 
many measurements as you like with the measurement function that has been 
selected. The continuous measurement mode is valid for all loaded images. You 
can, therefore, easily measure numerous images one after the other. 
The selected measurement function's button will keep its clicked appearance and 
in this way show you the current measurement function. You can recognize this 
status by the button's background color.  

You will remain in this measurement mode until you explicitly switch it off. To do 

this, click the Select Measurement Objects  button. You can find the button 
either in the Measurement and ROI tool window or on the toolbar.  

The continuous measurement mode described above is preset by default. You 
can change this default setting. To do this, use the Tools > Options... command. 
Select the Measurement and ROI > General entry in the tree view. Select the 
Switch to 'Select' mode after creation check box. Then, when you have 
completed a measurement, you will automatically leave the measurement mode 
again. This means you have to select the measurement function again before 
you start each interactive measurement. 

Prerequisite 
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Displaying and saving measurement results 
The measurement results will be displayed directly on the image and in the 
Measurement and ROI tool window. Use the View > Tool Windows > 
Measurement and ROI command to have the tool window displayed.  

The measurements will be saved along with the image, if you save the image in 
the TIF or VSI file format.  

You can, however, also export the measurement results in a results sheet, and 
save this as a file. To do this, use the Export to Excel or Export to Workbook 
command. You find both of the commands, e.g., in the Measure menu. 

The measurement results will be shown on the image in a special data layer, the 
measurement layer. On your monitor, image and measurement layer are shown 
together. The data of each, however, is individually stored if you use the TIF or 
VSI image file format. Try and picture the measurement layer as a transparency 
which is placed over the image. When you measure an image, the image data 
will not be changed by having the measurement results displayed on it.  

You can, at any time, hide or show the measurement layers.  
To do so, use the Layers tool window. There you have access to all of an image's 
layers. The eye icon  identifies all of the layers that are currently on display on 
your monitor.  
Click the eye icon in front of the measurement layer to hide the measurements. 
Click an empty cell without an eye icon to make the corresponding layer 
reappear. 

The unit in which the measurement results will be issued, is determined by the 
measurement function that has been selected and the image's calibration. But 
you can choose whether the length e.g., is shown in mm or µm.  
Use the Tools > Options... command. Select the Measurement and ROI > 
Results entry in the tree view. Select the unit you want to use from the Prefix of 
the unit list.  

You can export the measurement results from the Measurement and ROI tool 
window as a sheet, for example, to be able to save the measurement results in 
their own file, independently of the image. You will find the functions, e.g., as a 
button next to the measurement functions on the Measurement and ROI tool 
window's toolbar. 

Click the Export to Workbook  button to export measurement results from the 
Measurement and ROI tool window's results sheet to a workbook. Use this export 
possibility to save the measurement results in a file format that you can at any 
time load and edit with your software. 

Click the Export to Excel  button to export the results to an MS-Excel sheet. 
Use this export possibility, for example, when you want to evaluate the 
measurement results still further. This will also enable you to supply the results to 
other users who don't have your software.  

Editing measurements 
You can edit existing measurement objects at any time. To do this, click the 

Select Measurement Objects  button. You can find the button either in the 
Measurement and ROI tool window or on the toolbar.  

Please note: When you load an image file with measurement objects, it is only 
possible to edit the measurement objects if the image file has been saved in the 
TIF or VSI image file format. 

You can move a measurement object while keeping the left mouse button 
depressed.  
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You can also change the size of a measurement object. Move the 
mouse pointer onto a selection marker. By dragging the marker with the mouse 
button depressed, you can adjust the frame's size as wished. 

Click the [Del] key on your keyboard in order to delete the selected measurement 
object.  

The measurement values in the Measurement and ROI tool window will be 
correspondingly updated. 

You can, at any time, change the color, font and line thickness, of individual 
measurement objects. Select one or more measurement objects in an image and 
click your right mouse button to open a context menu. In the context menu you'll 
find several commands with which you can change the appearance of the 
selected measurement objects.  
From the context menu, select, e.g., the Change Color... command. Select the 
color you want from the color palette, then close the dialog box with OK.  

Measuring in the live mode 
All of the measurement functions are also available in the live-image. You can 
therefore, e.g., quickly measure a segment in the live-image. 

Measuring on different image types 
You can combine a series of separate images into one image. What results is 
e.g., a time stack in which all of the frames will have been acquired at different 
times. Further information on multi-dimensional images can be found in the 
online help. 

You can make measurements on every separate image. Display the required 
frame on your monitor. To do this, use the navigation bar in the image window. 
Then carry out the measurement on this frame. The measurement will be 
permanently linked to this frame, i.e., the measurement will only be displayed on 
your monitor when the frame on which you made this measurement is also on 
display. 
The measurement results will be shown in the Measurement and ROI tool 
window. You can give every measurement the number of the frame on which it 
was made. To do so, use, e.g., the measurement parameter "Index t" for time 
stacks. 

With some functions, e.g., with the Image > Combine Color Images... function, a 
multi-layer image will be created. This multi-layer image is made up of several 
layers. Further information on multi-layer images is available in the online help.  

Measurements always apply to one image layer. For this purpose, show the 
image layer on your monitor, on which you want to make measurements. To do 
so, use the Layers tool window. Then carry out the measurement on this image 
layer. The measurement will be permanently linked to this image layer, i.e., the 
measurement will only be displayed on your monitor when the image layer on 
which you made this measurement is also on display. 
The measurement results will be shown in the Measurement and ROI tool 
window. You can give every measurement the name of the image layer on which 
it was made. To do this, use the "Layer" measurement parameter. 

Increasing/decreasing 
the size of 

measurement objects 

Deleting measurement 
objects 
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measurement values? 
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Measurement precision 
How precise the measurement is, depends on the X/Y-calibration and the 
image's current zoom factor. 

The X/Y-calibration defines the width and height of the sample area that is 
represented by one pixel. For example, it could be that one pixel displays a 
sample area of 10 µm x 10 µm. A pixel is the smallest image structure that can 
be measured. For this reason, the maximum measurement precision where this 
example is concerned, is 10 µm. 

The zoom factor tells you how large the image will be displayed on your monitor. 
With a zoom factor of 100%, one pixel on the monitor equals exactly one pixel in 
the image. With a zoom factor of 50%, one pixel on the monitor equals 2 x 2 
pixels in the image. When you make a measurement, you should use the zoom 
factor 100% whenever possible. Then you will achieve a maximum of 
measurement precision. Should the zoom factor 100% not be possible, because 
the image area you want to measure can't then be completely seen, choose the 
largest possible zoom factor under 100%.  

00150 

6.2. Measuring images 
Your software offers a wide range of measurement functions. They enable you to 
quickly count objects and measure segments and areas.  

The following step-by-step instructions present the measurement functions to you 
by way of several examples. 

Measuring image objects interactively 
You want to measure the filaments in a supraconductor. 
To do this, load a suitable image, or acquire one. Measure the diameter of 
several of the hexagonal filaments, in each case between the opposing vertices.  
Subsequently edit the measurement. Delete some of the measurements you've 
made. Enter the results in a MS-Excel sheet. 

1. Use the View > Measurement and ROI command, to have the Measurement 
and ROI tool window displayed.  

 You'll find the tool window at the lower edge of the user interface. It's 
possible that it may be covered by the Count and Measure Results tool 
window. Click the Measurement and ROI tab at the bottom of the user 
interface, to bring the tool window into the foreground. 

2. Acquire an image or load one. 

 

 During the installation of your software some sample images have been 
installed, too. You can follow these step-by-step instructions when you 
use the exemplary image "SupraConductor.tif". Regarding the 
information as to where the example images are located, please refer to 
the online help. 

Influence of the X/Y-
calibration 

Influence of the zoom 
factor 
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The measurement results will be written into the image according to the default 
settings, in red font color and without a background. This can't be easily read 
against the superconductor's structure. Change the labeling settings. 

1. Use the Tools > Options... command.  

2. Click the Measurement and ROI > Measurement Display entry in the tree 
view.  

3. Click in the Background Color field, and choose, e.g., the color "Black". 

4. Select the Text color > Fixed colors option, then select the color "White" from 
the palette to see the measurements in white and the labeling in black in the 
image. 

5. Close the dialog box with OK. 

1. Click the Arbitrary Line   button, located on the toolbar at the top of the 
tool window.  

2. Click with your left mouse button at the starting point and end point of the 
reference distance. 

3. If you have measured a reference distance, you can immediately proceed 
with the next measurement. 

4. Click the Arbitrary Line   button again to end the length measurement. 

5. Take a look at the results in the tool window and in the image. 

 The illustration shows the image with three executed measurements. 
The measurement 2 has been selected 
 

 
1. Click one of the measurement results in the Measurement and ROI tool 

window.  

 The corresponding line will be marked in the image. 

2. Press the [Del] key.  

 The measurement will be deleted both in the image and in the tool 
window. 

 When a measurement has been deleted, the tool window and the image 
contain one measurement less. The IDs of the remaining measurements 
won't be changed by the deletion of a measurement. 

Setting the  
labeling color 

Measuring lengths 

Deleting measurements 
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When you've completed the measurements, you should switch off the 
measurement mode, since otherwise, you might inadvertently select your 
measurements and move them. 

3. Check whether one of the buttons on the Measurement and ROI tool 
window's toolbar appears clicked. Release this button 

1. To do this, click the Export to Excel  button. 

2. In the In/Output dialog box you set up the directory in which the data is to be 
saved, and enter the name of the MS-Excel sheet. Adopt the file type "Excel-
Sheet (*.xls)“. 

3. Click the Save button to have the MS-Excel sheet with the measurement 
results saved. 

1. Click the Close  button, located at the top right of the document group. 

 You have changed the image because you've added interactive 
measurements. For this reason, you'll receive a query whether you wish 
to save the image or not. 

2. Save the image in the TIF or VSI file format. The measurements will then 
also be saved in the image file. They can at any time, be edited deleted or 
augmented.  

Outputting various measurement parameters 
You want to measure the filaments in a supraconductor. 
Measure the hexagonal structure as a circular surface. Have a variety of 
measurement parameters, such as the area, the perimeter and the diameter, 
output. Have the diameter shown in the image. 

1. Acquire an image or load the "Supraconductor.tif" example image. Regarding 
the information as to where the example images are located, please refer to 
the online help. 

2. In the Measurement and ROI tool window, click the 2 Points Circle  
button. 

3. With your left mouse button, click in the center point of the hexagonal 
structure. 

4. Move your mouse, and in the process drag out the circle. Match the circular 
object as well as possible to the structure. Click your left mouse button. 

5. Click the 2 Points Circle  button again, and switch off the measurement 
mode. 

6. Take a look at the result in the Measurement and ROI tool window. 

 The illustration shows the image of the superconductor with a circular 
measurement. 

 
Exporting results to 
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1. In the Measurement and ROI tool window, click the Select Measurements 

 button. 

 In the dialog box you'll see a list with all of the available measurement 
parameters. At the bottom of the dialog box you'll see a list of the 
measurement parameters that are calculated for all objects. 

 A detailed description of the dialog box can be found in the online help. 

2. Go to the list of all of the available parameters, then click the "Diameter" 
measurement parameter.  

 On the right-hand side of the dialog box, an illustration shows you how 
the parameter is calculated.  
 

 
You can see that there are different ways in which the diameter of a 2D 
object can be calculated. 

3. Click the "Mean" entry in the list under the illustration to select the "Mean 
(Diameter)" measurement parameter. When you do this, the mean value of 
all of the possible diameters is determined. 

4. Click the Add 'Mean (Diameter)' button.  

 This measurement parameter will be adopted in the list. All of these 
measurement parameters will be displayed in the tool window. 

5. Close the dialog box with OK. 

6. Take a look at the result for the circle's diameter in the Measurement and 
ROI tool window. 

1. Open the Select Measurements dialog box.  

2. At the bottom of the list of all of the calculated measurement parameters, 
click the "Mean (Diameter)" measurement parameter.  

3. To the right of this list you'll see a button with a blue arrow . Click this 
button to move the measurement parameter to the top of the list. 

4. Close the dialog box with OK. 

5. Take a look at the result for the circle's diameter in the image.  

Tip: The measurement display in the image has to be updated once, so that the 
settings that have been changed are also taken into account. You update the 
measurement display, for instance, by adding another measurement, or by once 
selecting an existing measurement in the image. 

Viewing the list of 
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Measuring several images 
You want to measure the thickness of a spray coating. To do so, you acquire 
several images of the coating. Have the results from all images displayed 
simultaneously. Take a look at the mean value for all of the measurements. 

1. Acquire an image or load one. 

 

 During the installation of your software some sample images have been 
installed, too. You can carry these step-by-step instructions out directly 
with the example images "SprayCoating2.tif" and "SprayCoating4.tif". 
Regarding the information as to where the example images are located, 
please refer to the online help.  

2. Activate the first image in the document group. 

3. Click the Arbitrary Line  button located on the toolbar at the top of the 
Measurement and ROI tool window. Measure the thickness of the layer at 
several different places. 

4. Activate the next image. Measure the thickness of the layer at several 
different places, here also.  

5. Click the Arbitrary Line  button again, and switch off the length 
measurement. 

 The layer's thickness has been measured on both images. 
 

 
1. In the Measurement and ROI tool window, click the Measurement and ROI 

Options  button.  

2. Select the Measurement and ROI > Results entry in the tree view.  

3. Clear the Show measurement objects: Only of the active image check box.  

4. Close the dialog box with OK. 

 Now the results for both images will be shown simultaneously in the tool 
window. 

1. In the Measurement and ROI tool window, click the Measurement and ROI 

Options  button.  

2. Select the Measurement and ROI > Results entry in the tree view.  

 In the Statistic group you'll find various statistical parameters. 

3. Select the Mean check box.  

Task 
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4. Close the dialog box with OK. 

 Now, in the Measurement and ROI tool window under the measurement 
results, the chosen statistical parameter (1) will by shown. You can see 
there the mean value of the layer thickness for all of the measured 
images. 
 

 

Measuring heights 
To be able to make height measurements, you need to have a height map. A 
height map is a gray-value image whose gray values contain height information. 
The multi-dimensional image "Clockwork" is a Z-stack. Use the EFI algorithm to 
calculate the height map. Measure the height difference between the brass-
colored gear wheel in the middle image segment, and the silver-colored gear 
wheel on the right-hand side of the image. 

1. Load the "Clockwork.tif" image. Regarding the information as to where the 
example images are located, please refer to the online help.  

 The "Clockwork.tif" image is a Z-stack. The works of a clock was 
analyzed under a reflected light microscope. In the process, images of 
the works were acquired at different focus positions.  
In the illustration, the Z-stack is displayed in the tile view. Pay attention to 
the gear wheel that is only sharply reproduced in the middle of the Z-
stack. 

 
2. Use the Process > Enhancement > EFI Processing… command. 

3. Select the Apply on > All frames and channels option. 

4. From the Algorithm field select the Reflected light entry. 

5. Select the Height map check box. 

6. Select the Create new document as output check box. 

Task 
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7. Close the dialog box with OK. 

 You can see the EFI image with the clockwork's texture. The resulting 
image is a Multi-layer image and is therefore accompanied by this icon 

 in the image window's title.  

 The height map is a layer of the EFI image. The texture image makes up 
the second layer. The height information is therefore also present in the 
EFI image. You can measure the height directly on the texture image. 
 

 

1. In the Measurement and ROI tool window, click the 3D Line  button.  

2. Now measure the height between two image objects. 
Click, for example, the brass-colored gear wheel, and the silver-colored gear 
wheel on the right-hand side of the image. 
 

 

3. Click the 3D Line  button in the Measurement and ROI tool window 
again, then switch off the 3D measurement. 

 In the Measurement and ROI tool window, and in the image, the "3D 
Length" measurement parameter is output with the line's complete 
length. 
The "3D Intensity Projection" measurement parameter measures the 
height difference between two points. 

1. In the Measurement and ROI tool window, click the Select Measurements 

 button. 

2. In the list of all of the available measurement parameters, take a look at the 
parameter of the "3D Line" object type. 

3. Select the measurement parameter „3D Intensity Projection“. 
 

 
4. Insert this measurement parameter into the list of the displayed 

measurements. 

Measuring height 
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5. Close the dialog box with OK. 

 In the tool window you'll now see the "3D Intensity Projection" 
measurement parameter. It tells you how far in height, the two gear 
wheels are from each other. 

1. Use the View > Tool Windows > Layers command to make the Layers tool 
window appear. 

2. In the Layers tool window, click the [+] sign (1) and open the image's layers.  

 You can now see the image's individual layers. Height map (2) and 
texture image (3 ). The height map can't be seen, because it's absolutely 
transparent at the moment. 

 The measurements are on another layer (4). 
 

 
3. Select the height map in the Layers tool window.  

4. Click the Set Layer Opacity (5) button located on the toolbar at the top of the 
tool window.  

5. Drag the slider all the way to the right to an opacity of "100%", then take a 
look at the height map. 

 Low-lying structures can be recognized by their dark gray values, 
structures that lie higher, by their bright gray values. 

1. Click its eye icon  to make the corresponding layer disappear. By doing 
this, you can, e.g., for a time, remove the measurements from the image. 

2. Click an empty cell without an eye icon to make the corresponding layer 
reappear. 
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7. Performing a materials science 
analysis 
7.1. Tool window - Materials Solutions 

Use this tool window to measure an image, or several images at the same time, 
according to different material science analysis processes.  

The Materials Solutions tool window works similarly to a software wizard. As 
soon as you've started an analysis process you'll be guided step by step through 
the measurement.  

 

The top illustration shows the Materials Solutions tool window before an analysis 
process has been chosen. In the example shown, several analysis processes are 
available, as you can see from the three large buttons.  

 Chart comparison 
 Intercept analysis 
 Grains Planimetric 
 Layer Thickness 
 Cast Iron Analysis 
 Inclusion worst field 

Which of theses analysis processes are available to you, depends on the 
software license you've acquired. Maybe you will only see one or two analysis 
processes. 

  
Overview of the 
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processes 
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You start an analysis process by clicking the corresponding button. 

Tip: A lot of your software's other functions aren't available while an analysis 
process is running. For example, you can't open the program options then. 

Independent of which analysis process has been currently selected, the tool 
window is always configured in the same way. It comprises static and dynamic 
areas. 

 
The static areas (1), (3) and (4) are located at the top and bottom edges of the 
tool window. The contents of these areas is always largely similar. 

The dynamic area (2) is located in the middle part of the tool window. Its 
appearance differs according to which step and which analysis process has been 
chosen. 

You'll find the name of the current acquisition process right at the top of the tool 
window. In the Instructions group, you will find an instruction of what to do in this 
step and, if available, additional information. 

The contents of this area changes completely for each analysis process and for 
each step in the analysis. It is therefore described each time one of the different 
analysis process is presented.  

Here you can see at which step in the analysis you are at this moment. The 
current step is shown in bold font, and is indicated by a blue arrow. 

Here you find the buttons you use to proceed to the next step in the analysis, or 
to return to the previous step. You can also cancel an analysis here. Depending 
on the current step in the analysis, not all of the buttons are active. 

10242 
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7.2. What are chart comparisons? 
In metallography, chart comparisons are used as a means of quality control. 
They make it possible to compare an image with numerous reference images. 
The reference images are, as a rule, a part of the industry standards by which 
the chart comparisons are carried out.  

Example 1: 
During a qualitative grain size analysis, you determine the grain size of metallic 
samples. You compare the images that are to be checked with the reference 
images. You assign the reference image with grains of the same size to each of 
the images that is to be checked. 

Example 2: 
During a quality control, you check various components to see if they are free of 
defects. To do so, you compare the components with images of various 
components that are either defective or free of defects. You assign the 
appropriate reference image to the object that is to be checked . 

The image that is to be checked, and all or some of the reference images, are 
displayed simultaneously on the screen. Your software makes sure that all of the 
images are always shown on the same scale. By making a visual comparison, 
the user finds out which of the reference images is the most similar to the image 
that is to be checked. Saved along with every reference image is the value that it 
was assigned by the industry standard. By the selection of a reference image, 
the image that is to be checked is assigned this value, too.  

 

The above image shows the document group during a chart comparison. The 
image that is to be checked is located at the top left, the reference images are 
arranged either next to it or beneath it. The reference image you've selected will 
then be framed in red. 

The results of a chart comparison can be output in a workbook. As well as that, 
when you carry out chart comparisons on live-images, you can immediately 
reject the samples that don't meet the required values. 

Several predefined charts are supplied together with your software. The Single 
grain size and Austenitic grain size charts contain images with which the grain 
sizes can be determined.  

The Inclusions chart contains numerous images of various non-metallic 
inclusions (NMI). The NMIs show non-metallic inclusions of various types, and of 
various sizes. You can use the images to determine the type and size of the 
NMIs in your sample, by comparison.  

The process flow of a 
chart comparison 

Results 

Predefined  
charts 
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As well as that, the reference images of numerous international industry 
standards for material analysis can be incorporated.  

00723 

Performing a chart comparison 

Tip: A lot of your software's other functions aren't available while an analysis 
process is running. For example, you can't open the program options then. 
 
Example image "FerriteGrains.tif" 
 
When your software was installed, several example images have been copied 
automatically. You can immediately follow these step-by-step instructions when 
you use the example image "FerriteGrains.tif". Open this image and make sure 
that it has been selected in the document group. Regarding the information as to 
where the example images are located, please refer to the online help.  

Image source" step 
1. Activate the Materials Solutions tool window. Should this tool window not be 

visible, use the View > Tool Windows > Materials Solutions command to 
have it displayed. 

2. Click the Chart Comparison  button. 

3. In the Image source group, choose the Selected images option to analyze 
the "FerriteGrains.tif" image. This image must have been opened for this 
purpose, and have been selected in the document group. 

4. Select the Skip sample information check box, if you don't want to add any 
details about the sample or about an image of the sample. Should you want 
to add data, (e.g., because you are analyzing images of several samples in 
the same analysis), leave the check box unselected. 

5. Click the Next button. 

 The Materials Solutions tool window displays the next step. 

Sample information step 
You will only see this step in the analysis if, in the previous step, the Skip Sample 
Info check box wasn't selected. 

1. Enter information on your sample. By default, these fields are called 
Reference and Group.  

2. If you want to, enter a comment about the sample. This comment is valid for 
all of the images of this sample. 

3. If you want to, enter a comment about the current image, too. 

4. Click the Next button. 

 The Materials Solutions tool window displays the next step. 
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Settings step  
1. Select the chart by which you want to analyze the image. The Chart field 

contains some entries that are, by default, supplied with your software. As 
well as these, this group can contain additional or totally different entries, 
depending on which charged-for industry standards have been incorporated 
for your company. 

 Should no further industry standards have been incorporated in your 
case: Select, for the "FerriteGrains.tif" image, the Single grain size entry, 
to determine the grain size.  

2. Click the Next button. 

 The Materials Solutions tool window displays the next step. 

 In the document group, the new "Chart Comparison" document will be 
displayed. 

Comparison step 
1. In the Style group, choose how the images for the chart comparison are to be 

arranged in the document group. Choose an arrangement in which the 
"FerriteGrains.tif" image and the selected reference image are 

superimposed. To do this, click this  button. 

 In the document group, the "Chart Comparison" document will now be 
displayed. It contains exactly one image. 

 In the Overview field, you see the arrangement that has been chosen. 
The reference image you've selected will then be framed in red. 

 
2. Compare the structures of the current image with those of the reference 

image. Move the slide control below the Style field in the Opaque direction, if 
the image that is to be checked is to superimpose the reference image. 
Alternatively, move the slide control in the Transparent direction, if the image 
that is to be checked is to be superimposed by the reference image. 
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The illustration on the left shows the image that is to be checked. Because 
the slide control is located in the direction of the Opaque position, the 
reference image's structures can only be faintly recognized.  
 
For the illustration on the right, the slide control has been moved in the 
direction of the Transparent position. Now the reference image can be 
clearly recognized, and the image that is to be checked can be only faintly 
recognized. 

3. If you want to choose another reference image, in the Chart Comparison 
group, click that image with your left mouse button.  

4. When the reference image that is the most similar to the image that is to be 
checked, has been chosen: Click the Accept button. 

 The chosen image's data will be accepted in the Results field.  

 It's possible to accept several reference images, for example, with 
samples that have very different structures. 

5. Click the Next button. 

 The Materials Solutions tool window displays the next step. 

When you carry out analyses on the live-image: Click the Get Results button. 
You will then see the Results step. Otherwise, when you've finished analyzing 
one live-image, the next live-image will always then automatically be offered for 
analysis. 

Results step 
1. Select the Generate Workbook check box to have a document of the 

"workbook" type automatically created at the end of the analysis. 

2. Click the Finish button. 

 The Materials Solutions tool window switches back to the start position. 
You can now use all of your software's functions again. 

00724 
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7.3. What is an intercept analysis? 
The intercept analysis is used to measure grain sizes and to document them. It is 
often used in material analyses, for example, when the quality of steel or other 
metals is being tested.  

When an intercept analysis is made, measuring lines are placed in an image. 
Along these measuring lines, your software searches for abrupt deviations in the 
pixels' intensity (gray value). An intensity deviation occurs, for example, if dark 
pixels are present in an image made up of mainly light pixels. When an intensity 
deviation exceeds the parameters that have been set, an intercept point will be 
plotted at this position on the measuring line.  

The intercept points are counted. The distance between two intercept points is 
also measured. From this measurement, the mean intercept length is calculated. 

 
The intensity profile is determined along the horizontal measuring line. Whenever 
the measuring line crosses a grain boundary, this leads to a distinctive minimum 
in the intensity profile. When an intercept analysis is made, these minima in the 
profile are used to determine the intercept points. In the illustration shown, the 
grain boundaries are dark, the process can, however, also be used on images 
with light grain boundaries. The analysis of cascaded grain boundaries (with 
multi-phase materials) is also possible.  

An intercept analysis provides the so-called G-value, which is defined as a 
characteristic grain size in the corresponding industry standards. G is calculated 
from the number of intercept points and the mean intercept length. The grain 
sizes are measured in accordance with the industry standards: 

 ASTM E112 
 GB/T 6394 
 GOST 5639 
 ISO 643 
 DIN 50601 
 JIS G 0551 
 JIS G 0552 

The results of an analysis can be displayed in a workbook. Additionally, or 
alternatively to that, the results can be displayed in a MS-Word report. 

00700 
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Materials Solutions - Intercept analysis - Settings 

In this step, you make important settings for the analysis. The following 
possibilities are available: 

 
The line pattern determines along which lines the intercept points are looked for. 
At every position along the line, intensity deviations will be searched for in the 
intensity profile. As soon as an intensity deviation fulfills the definition criteria set, 
it will be displayed as an intercept point in the image. Which line pattern is 
suitable for a specific task, depends on the type of structures that are to be 
measured, and their position in the image. 

The following line patterns are available: 

Three circles are placed in the center of the image. The size of the measurement 
pattern corresponds to the diameter of the largest circle. This line pattern is 
appropriate for images with structures distributed equally throughout the image or 
structures which progress from the middle of the image to the edges. 

The cross consists of two diagonally crossed lines, as well as a line each below 
and to the left of this cross. The size of the measurement pattern corresponds to 
the length of the horizontal line below the cross.  

The Cross & Circles line pattern combines the two line patterns Cross and 
Circles. 

With this line pattern, horizontal lines are distributed evenly across the 
measurement pattern. 

With this line pattern, vertical lines are distributed evenly across the 
measurement pattern. 

With this line pattern, horizontal and vertical lines are distributed evenly across 
the measurement pattern, forming a grid. 
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Two slide controls are available. You can change the position of the slide 
controls however you want to in this step. This has an effect on the number of 
intercept points that will be found. Therefore you should keep an eye on the 
display in the image. 

Here you set the necessary width for the detection of a grain boundary. If the 
grain boundaries can be clearly recognized, a small grain boundary width is 
sufficient. The slide control can stand well over to the left, in this case. If the grain 
boundaries are difficult to recognize, you'll need to increase the grain border 
width. To do this, move the slide control to the right. When you are positioning 
the slide control, keep a constant eye on the number and quality of the intercept 
points found. 

Use this slide control to apply a smoothing filter to the image. The smoothing 
filter reduces the image noise. You should therefore apply a smoothing filter to 
images that are very noisy before the intercept analysis is made. Move the slide 
control from the left to the right, to increase the strength of the smoothing filter in 
small steps. When you do this, keep an eye on the number and quality of the 
intercept points found. 

Here you specify which criteria are used to detect the grain boundaries. 
Depending on the image that is to be analyzed, the grain boundary type can be 
dark (left illustration) or light (middle illustration). Where images that don't have 
any intensity deviations, but only show different gray values, are concerned, 
select the Step setting (right illustration).  

             

These fields are only active if you selected a line pattern that contains horizontal 
or vertical lines. In this case, you specify here the number of lines to be used for 
the intercept analysis. 
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Performing an intercept analysis 

Tip: A lot of your software's other functions aren't available while an analysis 
process is running. For example, you can't open the program options then. 

Image source" step 
1. Activate the Materials Solutions tool window. Should this tool window not be 

visible, use the View > Tool Windows > Materials Solutions command to 
have it displayed. 

2. Click the Grains Intercept  button. 

3. In the Image source group, choose the image resp. images that you want to 
analyze. When you do this, pay attention to the information as to how many 
images have been selected This information is shown in bold font at the 
bottom of the group. The following options are available: 

 Live image option: With this option, the additional step Image acquisition 
will be shown. In this step, an image of the live-image is acquired, that is 
then analyzed in the steps that follow. When the Image results step has 
been completed, a new image of the live-image will be automatically 
acquired, then analyzed. This enables you to analyze as many images 

(2) Slide controls for 
changing the results 

displayed 

Grain boundary width 

Noise reduction 

(3) Buttons for selecting 
the grain boundary type 

(4) Number of test lines 



Performing a materials science analysis

 

60 

as you want during the same measurement. You can then either save 
the analyzed images, or reject them. 

 Selected images option: Loaded images that are currently selected in the 
Gallery tool window. Loaded images that haven't been selected in the 
Gallery tool window will be ignored for the analysis. 

 System folder option: All of the images in a specific directory. You can 
choose the directory as you wish. 

 Selected database images option: All of the images you have currently 
selected in your software's database. 

4. Decide whether you want to load settings that you have saved while you 
were analyzing another image. Then you can, if necessary, adapt these 
settings and apply them to this image. Click the Load from file... button to 
load the settings that have been saved. 

5. Decide whether or not you want to add data about the sample or about 
individual images while the analysis process is in progress. If you don't want 
to do so, select the Skip Sample Info check box.  
Should you want to add data, (e.g., because you are analyzing images of 
several samples in the same analysis), leave the check box unselected. 

6. Click the Next button. 

 The Materials Solutions tool window displays the next step. 

 Should you be analyzing the live-image and a database is open, you'll be 
asked whether you want to save the acquired individual image in the 
database. 

Sample information step 
You will only see this step in the analysis if, in the previous step, the Skip Sample 
Info check box wasn't selected. 

1. Enter information on your sample. By default, these fields are called 
Reference and Group.  

 If you have changed the default settings, these fields can also have 
another name. Further information on how to change the default settings 
is available in the online help. 

2. If you want to, enter a comment about the sample. This comment is valid for 
all of the images of this sample. 

3. If you want to, enter a comment about the current image, too. 

4. Click the Next button. 

 The Materials Solutions tool window displays the next step. 

Settings step 
1. Choose a line pattern that is appropriate for the structures in the image that 

is to be analyzed. You can choose between various line patterns.  

 The pattern determines along which lines, intercept points in the image 
are looked for. 

2. Take a look at the intercept points that have been found in the image. If 
necessary, change the settings to optimize the results shown.  

3. Click the Next button. 

 The Materials Solutions tool window displays the next step. 
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Image results step 
1. Check the results shown. You can see the results of the current image, and 

the overall results of all of the images that have already been analyzed for 
this sample.  

2. Should you not be satisfied with the results for the current image: Click the 
Back button to switch back to the Settings step. Then you can try to improve 
the results for this image by choosing another line type or by moving the slide 
controls to another position. 

3. Should you want to correct the intercept points that have been automatically 
found, click the Add... or Delete... buttons. This will enable you to add 
intercept points manually, or to delete superfluous intercept points. You will 
find step-by-step instructions on how to correct intercept points in the online 
help. 

4. Select the Check settings check box, to have the Settings step displayed with 
every image.  

 This enables you to individually change the slide control's setting before 
every individual image is analyzed. This makes sense, for example, if the 
images that are to be analyzed are of greatly different quality, and you 
need to adjust the noise reduction individually for each image.  

 The Check settings button is only active if you analyze several images of 
a sample at the same time. 

5. When you analyze images that you selected before the analysis began: Click 
the Next button. 

 Should you analyze images from the database, you will then be asked 
whether you want to save the changed images, or not. You can either 
insert the analyzed images as new images into the database, or 
overwrite the existing database images with them. As well as that, you 
can either save the images in the file system or reject them. 

 The Materials Solutions tool window displays the next step. 

 Only when you carry out an analysis on the live-image, or you want to 
leave out the analysis of all of the remaining images: Click the Get 
Results button. You will then see the Results step. Otherwise, when 
you've finished analyzing one live-image, the next live-image will always 
then automatically be offered for analysis. 

Results step 
1. Check the results shown. You can see the overall results for all of the 

images, that have already been analyzed for this sample. 

2. Select the Generate Report check box, if you want to have a report 
automatically generated in the MS-Word application program once the 
analysis is completed. 

 The additional step Reporting will be added to the current analysis. In the 
lower part of the dialog box, the Finish button will change into the Next 
button.  

3. Select the Generate Workbook check box to have a document of the 
"workbook" type automatically created at the end of the analysis. 

4. If you want to save the current settings to a file, click the Save to file.... 
button. Then assign a descriptive name in the next dialog box. 
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 You can load these settings (parameters) when you analyze further 
images. To do so, load the image to be analyzed, then click the Load 
from file... button, in the Image source step. The sample and image 
comments, the line pattern used, and the position of the slide controls in 
the Settings step will be saved. 

5. Click the Next button. 

Reporting step 
1. Select the Default option, to use the document template that has been 

defined as default document template. The document template determines, 
e.g., the appearance of the report's header and footer.  

 Should you want to change the default document template, use the Tools 
> Options > Report Composer > Document Templates command. Add 
the document template you want to the Templates list, select it and click 
the Set as Default button. 

2. In the Content group, select the check box for the pages the report should 
contain. 

 Select the Summary page check box, if the first page of the report is to 
contain a summary of all of the results of the current analysis. The 
creation of a summary page can, e.g., be useful, when you have 
analyzed a large number of images of a variety of different samples. 

 Select the One page per sample check box, if the report should contain 
one page for every sample. This page displays the overall results for all 
of the images belonging to that sample. Using this setting is a good idea, 
for example, when you have analyzed images of different samples. 

 Select the One page per image check box, if the report should contain a 
page of its own for every image. Should only this check box have been 
selected, and you have analyzed three images, your report will contain 
exactly three pages. 

3. Click the Finish button. 

 The report will be generated and displayed in the MS-Word application 
program. 

 The workbook will be created. It always contains a minimum of two 
worksheets. On the first worksheet you'll see a summary of the results. 
On the second worksheet you'll see the details concerning the sample 
used. Should you have analyzed several samples, the workbook will 
contain additional worksheets. 

 The Materials Solutions tool window switches back to the start position. 
You can now use all of your software's functions again. 
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7.4. What is Grains Planimetric? 
The grains planimetric analysis is used to measure grain sizes and to document 
them. It is often used in material analyses, for example, when the quality of steel 
or other metals is being tested. The grains planimetric analysis determines the 
grain size by means of the grains' area. In this way, it differs from the Intercept 
analysis, that determines the grain size by means of the number of intercept 
points. 

Samples with dark grain boundaries or samples with bright grain boundaries can 
be used. The analysis of cascaded grain boundaries (with multi-phase materials) 
is also possible.  

      

 

The image shown above shows the results of an automatic detection of the grain 
boundaries. The grain boundaries that have been detected are plotted in red (first 
illustration).  
Additionally, it's possible to have the grains that have been found displayed in 
color (second illustration). When this is done, the original image isn't changed, 
because this information is written to another image layer. 

You can manually edit the grain boundaries that your software found 
automatically. When you do this, you have the possibility of deleting superfluous 
grain boundaries and adding boundaries that are missing.  

A grains planimetric analysis provides the so-called G-value, which is defined as 
a characteristic grain size in the corresponding industry standards. The grain 
sizes are measured in accordance with the industry standards: 

 ASTM E112 
 GB/T 6394 
 GOST 5639 
 ISO 643 
 DIN 50601 
 JIS G 0551 
 JIS G 0552 

The results of an analysis can be displayed in a workbook and in a chart. 
Additionally, the results can be displayed in a MS-Word report. 
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Materials Solutions - Grains planimetric - Settings 

In this step, you make important settings for the analysis. You'll only see some of 
the setting options described below, which of them you see depends on the 
image type you chose in the previous Image type information step.  

 
The positioning of the slide controls influences the detection of the grain 
boundaries. While you are positioning the slide controls, observe which grain 
boundaries are found. The preview is updated after every change in the settings. 

Position the slide controls in such a way that the grain boundaries are detected 
as completely as possible. It doesn't matter if pixels are detected within a grain 
as well. The algorithm that calculates the G-value ignores all of the pixels within a 
grain. 

Make sure that the correct grain boundary type has been set, before you adjust 
the positions of the other slide controls.  

You'll only see this slide control when you chose the "Flat etched grains" image 
type in the previous step. 

With this slide control you set the necessary width for the detection of a grain 
boundary. If the grain boundaries can be clearly recognized, a small grain 
boundary width is sufficient. The slide control can, in this case, stand on the far 
left (in the direction of the Small position). If the grain boundaries are difficult to 
recognize, you'll need to increase the grain border width. To do so, move the 
slide control to the right (in the direction of the Large position).  

     

In first illustration, the selected grain boundary width is too small. The grain 
boundaries haven't been completely detected. 
In the second illustration, the grain boundary width has been increased. Now the 
grain boundaries have been completely detected. 

(1) Slide controls  

Grain boundary width 
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You can use the program options to change the color in which the detected grain 
boundaries are shown. Further information is available in the online help. 

Choose whether a smaller intensity value range is sufficient for the detection of a 
grain boundary. This is,  e.g., the case, when all of the grain boundaries stand 
out clearly against the background. In this case, you can move the slide control 
to the far right (in the direction of the High position). 

If all of the grain boundaries don't stand out clearly against the background, e.g., 
because some grain boundaries are brighter than others, a larger intensity value 
range has to be defined for the detection of the grain boundaries. In this case, 
move the slide control to the far left (in the direction of the Low position). 

     

In the first illustration, the selected threshold value is too high. Some of the grain 
boundaries haven't been detected. 
In the second illustration, a lower value for the threshold values has been given. 
The grain boundaries have now been correctly detected. 

You'll only see this slide control if you chose the "Color etched grains" image type 
in the previous step. 

With the help of this slide control you can specify to which size artifacts that are 
located within the grains are to be ignored for the analysis. Detected artifacts are 
taken for small grains by the software, and therefore influence the results of the 
planimetric measurement.  

Set the degree of image smoothness in such a way that artifacts are just no 
longer detected. Don't choose a greater value than necessary. When the image 
smoothness chosen is unnecessarily great, "real" small grains won't be detected 
otherwise.  

       

In the first illustration, the selected image smoothness is too small. With this 
setting, numerous artifacts within the grains are detected, which negatively 
affects the results of the planimetric measurement.  

In the second illustration, a higher value for the image smoothness has been 
chosen. You can clearly see that only a few artifacts were still detected within the 
grains. These artifacts therefore hardly influence the planimetric measurement at 
all. 

 

You'll only see these buttons when you chose the "Flat etched grains" or "Ferritic 
grain size with pearlite" image type, in the previous step. 

Here you specify which criteria are used to detect the grain boundaries. 
Depending on the image that is to be analyzed, the grain boundary type can be 
bright or dark. Therefore, this slide control can only stand at the position Dark or 
Bright. 

Threshold 

Smoothness 

(2) Buttons for selecting 
the grain boundary type 
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In the illustration on the left, the grain boundaries are dark. In the illustration on 
the right, the grain boundaries are bright.  
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Performing a planimetric measurement 

Tip: A lot of your software's other functions aren't available while an analysis 
process is running. For example, you can't open the program options then. 

Image source step 
1. Activate the Materials Solutions tool window. Should this tool window not be 

visible, use the View > Tool Windows > Materials Solutions command to 
have it displayed. 

2. Click the Grains Planimetric  button. 

3. In the Image source group, choose the image resp. images that you want to 
analyze. When you do this, pay attention to the information as to how many 
images have been selected This information is shown in bold font at the 
bottom of the group. The following options are available: 

4. Decide whether you want to load settings that you have saved while you 
were analyzing another image. Then you can, if necessary, adapt these 
settings and apply them to this image. Click the Load from file... button to 
load the settings that have been saved. 

5. Decide whether or not you want to add data about the sample or about 
individual images while the analysis process is in progress. If you don't want 
to do so, select the Skip Sample Info check box.  
Should you want to add data, (e.g., because you are analyzing images of 
several samples in the same analysis), leave the check box unselected. 

6. Click the Next button. 

 The Materials Solutions tool window displays the next step. 

Sample information step 
You will only see this step in the analysis if, in the previous step, the Skip Sample 
Info check box wasn't selected. 

1. Enter information on your sample. By default, these fields are called 
Reference and Group.  

 If you have changed the default settings, these fields can also have 
another name. Further information on how to change the default settings 
is available in the online help. 

2. If you want to, enter a comment about the sample. This comment is valid for 
all of the images of this sample. 

3. If you want to, enter a comment about the current image, too. 

4. Click the Next button. 

 The Materials Solutions tool window displays the next step. 
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Image type information step 
1. Click the image type that the image that is to be analyzed most resembles. 

The current image type is framed in yellow. 

 The image type determines the algorithm that is to be used for the 
determination of the grain sizes. 

2. Click the Next button. 

 The Materials Solutions tool window displays the next step. 

Settings step 
1. Click the button that is equivalent to the grain boundaries in your sample 

(e.g., dark grain boundaries against a bright background).  

2. With the Grain boundary width slide control, you set the necessary width for 
the detection of a grain boundary. If the grain boundaries can be clearly 
recognized, a small grain boundary width is sufficient. The slide control can, 
in this case, stand on the far left (in the direction of the Small position). If the 
grain boundaries are difficult to recognize, you'll need to increase the grain 
border width. To do so, move the slide control to the right (in the direction of 
the Large position).  

 You'll only see this slide control when you chose the "Flat etched grains" 
image type in the previous step. 

 You can use the program options to change the color in which the 
detected grain boundaries are shown. Further information is available in 
the online help. 

3. With the Threshold slide control, you set the intensity value range for the 
detection of a grain boundary. If all of the grain boundaries can be clearly 
made out against the background, move the slide control to the far right (in 
the direction of the High position).  
If all of the grain boundaries can't be clearly made out against the 
background, e.g., because some grain boundaries are brighter than others, 
move the slide control to the far left (in the direction of the Low position). 

4. With the Smoothness slide control, set the degree of the image smoothness 
in a way that artifacts located within the grains are just not detected. Don't 
choose a greater value than necessary. 

 Detected artifacts are taken for small grains by the software, and 
therefore influence the results of the planimetric measurement. When the 
image smoothness chosen is unnecessarily great, "real" small grains 
won't be detected otherwise.  

 You'll only see these slide controls when you chose the "Color etched 
grains" image type in the previous step. 

5. Click the Next button. 

 The Materials Solutions tool window displays the next step. 
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Image results step 
1. Check the results that are displayed in the image and in the Materials 

Solutions tool window.  

 In the image, the grains that have been detected are now displayed in 
color. Only the colored grains will be taken into account when the G-
value is calculated. If you want to have the grain boundaries shown 
together with the image, clear the Show grains check box, in the Display 
group. 

 In the Materials Solutions tool window, you'll see the mean grain size 
number G for the current sample or for the current image. As well as 
that, the allocation of the detected grain sizes to the different size 
classes will be displayed graphically.  

2. Should you not be satisfied with the results for the current image: Click the 
Back button to switch back to the Settings step. Then you can try to improve 
the results for the images by using another position of the slide controls. 

3. If you want to correct the automatically found grain boundaries, click the Add 

grain boundaries in free-hand mode... , Add grain boundaries in guided 

mode...  or Delete grain boundaries...  button. You will find step-
by-step instructions on how to correct grain sizes in the online help. 

4. Select the Check settings check box, to have the Settings step displayed with 
every image. This button is only active if you analyze several images of a 
sample at the same time. 

 This enables you to individually change the slide control's setting before 
every individual image is analyzed. This makes sense, for example, if the 
images that are to be analyzed are of greatly different quality, and you 
need to adjust the noise reduction individually for each image.  

 You can select or clear the Check settings check box during a running 
analysis. This change will then be valid from the next image onwards. 

5. When you analyze images that you selected before the analysis began: Click 
the Next button. 

 Should you analyze images from the database, you will then be asked 
whether you want to save the changed images, or not. You can either 
insert the analyzed images as new images into the database, or 
overwrite the existing database images with them. As well as that, you 
can either save the images in the file system or reject them. 

 The Materials Solutions tool window displays the next step. 

 Only when you carry out an analysis on the live-image, or you want to 
leave out the analysis of all of the remaining images: Click the Get 
Results button. You will then see the Results step. Otherwise, when 
you've finished analyzing one live-image, the next live-image will always 
then automatically be offered for analysis. 
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Results step 
1. Check the results shown. You can see the overall results for all of the 

images, that have already been analyzed for this sample. 

2. Select the Generate Report check box, if you want to have a report 
automatically generated in the MS-Word application program once the 
analysis is completed. 

 The additional step Reporting will be added to the current analysis. In the 
lower part of the dialog box, the Finish button will change into the Next 
button.  

3. Select the Generate Workbook check box to have a document of the 
"workbook" type automatically created at the end of the analysis. 

4. Select the Generate Chart check box, to save the graphic display of the 
allocation of the detected grain sizes to the different size classes. It is the 
same chart that was displayed in the previous Image results step in the 
analysis. 

5. If you want to save the current settings to a file, click the Save to file.... 
button. Then assign a descriptive name in the next dialog box. 

6. Click the Next button. 

Reporting step 

1. If you want to, click the button with the three points , located to the right 
of the Template field, to change the document template. The document 
template determines, e.g., the appearance of the report's header and footer. 
Then select the new document template in the Open dialog box.  

 Even if no document template has been registered, you can still generate 
a report. In this case, the same document template will be used as 
Microsoft Word uses when you set up a new Word file. This default 
document template is, as a rule, called "normal.dot". 

2. In the Content group, select the check box for the pages the report should 
contain. 

3. Click the Finish button. 

 The report will be generated and displayed in the MS-Word application 
program. 
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7.5. What are layer thickness measurements? 
By using layer thickness measurements you can measure layers on calibrated 
images automatically or interactively. The object that is to be measured is the 
thickness of one layer or of several layers.  

Each layer is defined by two borders and a neutral fiber. The neutral fiber is a 
reference line which is there to specify the layer's course. The neutral fiber is 
automatically defined by the program.  

You can define either open or closed layer types. When you have a closed layer 
type, you can measure circular layer structures. In this mode, the measurement 
line's first point is automatically connected to its last point. 

 

Measuring an open layer: In the image, two layers have been measured. You 
can see 4 layer borders (blue lines) and two neutral fibers (green lines). The 
measurement lines (yellow lines) are shown for the currently selected layer. 

 

 

Measuring a closed layer: In the image, the outer layer has been measured. You 
can see the layer borders (blue lines), the neutral fiber (green line) and the 
measurement lines (black lines). 

The results of an analysis can be displayed in a workbook. Additionally, or 
alternatively to that, the results can be displayed in a MS-Word report.  

Results of a layer 
thickness measurement 
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The borders that have been found, the neutral fibers and the measurement lines 
will be saved together with the image, if you save it in TIF or VSI format. This 
information will be saved in a separate image layer that you can show and hide 
via the Layers tool window. 

 

1. In the Materials Solutions tool window, click the Layer Thickness button. 

 
2. Choose the image you want to measure. 

 
3. Choose the definition method you want to use  

(Automatic, Manual, Magic Wand). 

 
4. Define the contours. 

 
5. Define the borders.  

 
6. Define the layers. 

 
7. Take a look at the measurement results. 

 
8. Document the results (report or workbook). 
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Performing an automatic layer thickness measurement 

You can follow the following step-by-step instructions on your PC. They describe 
a layer thickness measurement on an example image.  

"Image source" step 
1. Load the "Coating.tif" example image. Regarding the information as to where 

the example images are located, please refer to the online help.  

 On this image, the thin light layer is to be measured. 

 
2. Activate the Materials Solutions tool window.  

3. Click the Layer Thickness  button. 

4. Select the Skip 'Sample information' check box.  

5. Click the Next button. 

"Settings"step 

1. Click the Automatic  button.  

2. In the Layer type group, click the icon for an open layer .  

3. Click the Next button. 

"Automatic" step 
1. You see the image on which some of the image structures are now  shown in 

color, because the first phase was automatically set up.  

 
2. Since the required image structures are not yet shown in color, select the 

Dark option in the Background group.  

 Now the required image structures are shown in color.  
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3. Click the Next button.  

"Define borders" step 
1. Here you see the image in which the contours are outlined in red. 

 

2. Click the Define borders...  button. 

3. Now specify which part of the contour represents a border. Click the contour 
once with your left mouse button, to activate the mode.  
Then click with your left mouse button at the position in the contour where 
the first border is to begin. 
Then click with your left mouse button at the position in the contour where 
the first border is to end. 

 The beginning and the end of this border will be indicated by two green 
crosses.  

4. Now define the second border. To do so, click with your left mouse button 
again at the position where this border is to begin. Then click with your left 
mouse button again at the position where this border is to end. 

 The beginning and the end of this second border will be indicated by two 
blue crosses.  

5. Click once with your right mouse button in the image. 

 The borders that have been defined will be plotted in blue.  

 
6. Since you don't want to define any additional borders: Then click once more 

with your right mouse button in the image, to switch off the mode for defining 
the borders.  

7. Click the Next button. 
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"Edit borders" step 
1. Since you have already defined both of the borders, and don't want to 

change them: Click the Next button. 

"Define layers" step 

1. Click the Add layers...  button.  

2. Click the first border. 

3. Click the second border, then click your right mouse button. 

 The layer has now been defined. The neutral fiber is plotted in green. It 
always lies in the middle of the layer.  

 
4. Click the Next button. 

"Image results" step 
1. Take a look at the results of the current image, shown in the Image results 

group. This group contains a table with the measurement results.  

 The values in the Steps, Distance and Type fields can be edited when 
you doubleclick in the cell you want to edit. 

 The lower part of the group contains several buttons, with which you can 
change the way the layer thickness measurement is displayed. Further 
information is available in the online help. 

2. Check the results shown in the image. 

 The measurement lines are shown in yellow in the image. 

 
3. Click the Next button. 

"Results" step 
1. Select the Generate Workbook check box to have a document of the 

"workbook" type automatically created at the end of the analysis.  

 Leave the Create report check box cleared for these step-by-step 
instructions.  

2. Click the  Finish button. 

 The workbook will be created.  

 The analysis has now been completed. The Materials Solutions tool 
window switches back to the start position. You can now use all of your 
software's functions again. 
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Performing a layer thickness measurement with the magic wand 
(open layer) 

You can follow the following step-by-step instructions on your PC. They describe 
a layer thickness measurement on an example image. The example image 
shows an open layer.  

Please note: The procedure is slightly different when you measure a closed 
layer. You will find separate step-by-step instructions on how to measure closed 
layers in the online help. 

"Image source" step 
1. Load the "Painting Coat.tif" example image. Regarding the information as to 

where the example images are located, please refer to the online help.  

 On this image, the topmost layer is to be measured. 

 
2. Activate the Materials Solutions tool window.  

3. Click the Layer Thickness  button. 

4. Select the Skip 'Sample information' check box.  

5. Click the Next button. 

"Settings" step 

1. Click the Magic Wand  button.  

2. In the Layer type group, click the icon for an open layer .  

3. Click the Next button. 

"Magic wand" step 

1. Click the Add contours...  button. 

2. Click the button for the HSV color space  . 

3. Then define the first contour. To do this, click once with your left mouse 
button on a position in the image within the layer that is to be measured. 
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 The contour will be shown by a red line. 
 

 
4. It's possible that the contour won't completely contain the image structure 

you want. Alternatively, it can happen that too much space has been 
detected around the image structure. In this case, increase the value in the 
Tolerance field, until the contour roughly includes the layer that is to be 
measured.  

5. Click your right mouse button to finish the definition of the contour.  

6. Click the Next button. 

 The Define borders step in the analysis will be shown. 

"Define borders" step 

1. Click the Define borders...  button. 

2. With your left mouse button, click once at any position in the contour to 
activate the mode. 

3. Then click with your left mouse button at the position in the contour where 
the first border is to begin. 

 A green cross indicates the border's starting point. 

4. Then click with your left mouse button at the position in the contour where 
the first border is to end. 

 A second green cross indicates the border's end point. 

5. Define the second border. To do this, click again at the two positions in the 
contour at which this border is to begin and end. 

 The beginning and the end of this second border will be indicated by two 
blue crosses.  

 
6. Then click with your right mouse button at any place in the image, to switch 

off the mode.  
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 The detected contour will disappear. The borders that have been defined 
will be plotted as a blue line. 

 
7. Click the Next button. 

"Edit borders" step 
1. Since you have already defined both of the borders, and don't want to 

change them: Click the Next button. 

"Define layers" step 

1. Click the Add layers...  button.  

2. Click the first border. 

3. Click the second border. 

 The layer has now been defined. The neutral fiber is plotted in green. It 
always lies in the middle of the layer. 

 
4. Click your right mouse button to finish the definition of the layer. 

5. Click the Next button. 

"Image results" step 
1. Take a look at the results of the current image, shown in the Image results 

group. This group contains a table with the measurement results.  

 The values in the Steps, Distance and Type fields can be edited when 
you doubleclick in the cell you want to edit. Further information is 
available in the online help. 

 The lower part of the group contains several buttons, with which you can 
change the way the layer thickness measurement is displayed. Further 
information is available in the online help. 

2. Check the results shown in the image. 

 The measurement lines are shown in yellow in the image. 
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3. Click the Next button. 

"Results" step 
1. Select the Generate Workbook check box to have a document of the 

"workbook" type automatically created at the end of the analysis.  

 Leave the Create report check box cleared for these step-by-step 
instructions.  

2. Click the  Finish button. 

 The workbook will be created.  

 The analysis has now been completed. The Materials Solutions tool 
window switches back to the start position. You can now use all of your 
software's functions again. 

00729 

Performing a manual layer thickness measurement 

You can follow the following step-by-step instructions on your PC. They describe 
a layer thickness measurement on an example image.  

"Image source" step 
1. Load the "Coating with porosity.tif" example image. Regarding the 

information as to where the example images are located, please refer to the 
online help.  

 On this image, the middle layer is to be measured. 

 
2. Activate the Materials Solutions tool window.  

3. Click the Layer Thickness  button. 

4. Select the Skip 'Sample information' check box.  

5. Click the Next button. 
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"Settings" step 

1. Click the Manual  button.  

2. In the Layer type group, click the icon for an open layer .  

3. Click the Next button. 

"Manual" step 

1. Click the Add borders...  button. 

2. Define the first border. To do so, first click with your left mouse button at the 
position in the image where the border is to begin. Mark the course of the 
border with further left mouse clicks. Then click with your right mouse button 
at the position in the image where the border is to end. 

 The border will be shown in red. 

3. Define the second border. To do this, proceed exactly as you did when you 
defined the first border. 

4. Click your right mouse button to finish the definition of the two borders.  

 The borders will be shown in blue. 

 
5. Click the Next button. 

 The Materials Solutions tool window displays the Edit borders step.  

"Edit borders" step 
1. Since you have already defined both of the borders, and don't want to 

change them: Click the Next button. 

"Define layers" step 

1. Click the Add layers...  button.  

2. Click the first border. 

3. Click the second border, then click your right mouse button. 

 The layer has now been defined. The neutral fiber is plotted in green. It 
always lies in the middle of the layer.  
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4. Click the Next button. 

"Image results" step 
1. Take a look at the results of the current image, shown in the Image results 

group. This group contains a table with the measurement results.  

 The values in the Steps, Distance and Type fields can be edited when 
you doubleclick in the cell you want to edit. Further information is 
available in the online help. 

 The lower part of the group contains several buttons, with which you can 
change the way the layer thickness measurement is displayed. Further 
information is available in the online help. 

2. Check the results shown in the image. 

 The measurement lines are shown in yellow in the image. 

 
3. Click the Next button. 

"Results" step 
1. Select the Generate Workbook check box to have a document of the 

"workbook" type automatically created at the end of the analysis.  

 Leave the Create report check box cleared for these step-by-step 
instructions.  

2. Click the  Finish button. 

 The workbook will be created.  

 The analysis has now been completed. The Materials Solutions tool 
window switches back to the start position. You can now use all of your 
software's functions again. 

00731 



Performing a materials science analysis

 

81 

7.6. What is a cast iron analysis? 
The quality and consistency of cast iron depends on the distribution and the 
morphology of its carbon content. By using a cast iron analysis you can 
determine the cast iron's graphite fraction with the help of unetched samples. As 
well as that, with the help of etched samples you can determine the 
ferrite/pearlite ratio.  

The classification of the detected particles is performed according to the 
industrial standard that is selected in the program options. Each standard 
requires a different classification of the detected particles. These classifications 
are included in the software package purchased, and are automatically installed 
with it. The following standards are supported: 

 ASTM A 247 2006  
 EN ISO 945  
 EN ISO 945-1  
 KS D 4302-2006 
 JIS G 5502-2001 
 GBT 9441 

By using your software's Cast Iron Solution, you can measure the graphite 
fraction and classify the detected particles. For this purpose, the sample must 
have been etched. How the classes are defined, depends on the standard 
according to which the cast iron analysis is carried out. The standard is set in the 
program options. 

   

 

You see the results of a cast iron analysis made of different forms of graphite. 
The color coding of the particles indicates their belonging to a specific size class 
(1), form class (2), and a form factor (3).  

Determination of the 
graphite fraction 
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The results of an analysis can be displayed in a workbook. Additionally, or 
alternatively to that, the results can be displayed in a MS-Word report. 

While you are performing a cast iron analysis, you can create a chart showing 
the graphite size, the graphite form or the graphite nodularity. You can also save 
these charts as files.  

  

 

Illustration (1) shows a chart of the graphite size. Along the X-axis the size 
classes are shown, along the Y-axis the number of detected particles 

Illustration (2) shows a chart of the graphite form. Along the X-axis the form 
classes are shown, along the Y-axis the number of detected particles. 

Illustration (3) shows a chart of the graphite nodularity. Along the X-axis the form 
factor is shown, along the Y-axis the number of detected particles. 

 

1. In the Materials Solutions tool window, click the Cast iron button. 

 
2. Choose the image you want to measure. 

 
3. Choose the sample type (etched). 

 
4. Set the graphite parameters. 

 
5. If chosen: Determine the distribution of the graphite particles.  

 
6. Take a look at the image results. 

 
7. If necessary: Delete or separate detected particles, or add new ones. 

 
8. Document the results (report or workbook). 

Results of a cast iron 
analysis made to 

determine the graphite 
fraction 

  
Usual process flow of a 
cast iron analysis made 

to determine the 
graphite fraction 
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By using your software's Cast Iron Solution, you can also measure the 
ferrite/pearlite ratio. For this purpose, the sample must have been etched. Since 
graphite and pearlite have very similar gray values, it's difficult to differentiate 
between these two fractions in a sample during the same analysis. For this 
reason, determining the ferrite/pearlite ratio is done as follows: 

To begin with, your software determines, by means of the definition of phases, 
the ratio of the bright ferrite areas to the dark (graphite and ferrite) areas. During 
the analysis, the graphite fraction is entered, and is then subtracted from the dark 
areas. This graphite fraction has either been determined in an earlier 
measurement (this value can then be imported), or it can alternatively be 
estimated. Using the pearlite area that has in this way been corrected, the 
ferrite/pearlite ratio is calculated.  

 

You see a step in the analysis during the determining of the ferrite/pearlite ratio. 
The bright ferrite phase has been determined by your software (shown in yellow 
here). 
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Performing a cast iron analysis (unetched sample) 

You can follow the following step-by-step instructions on your PC. They describe 
how the graphite fraction is determined. 

"Image source" step 
1. Load the "GlobularGraphite.tif" example image.  

 The graphite fraction is to be measured. 

2. Activate the Materials Solutions tool window. Should this tool window not be 
visible, use the View > Tool Windows > Materials Solutions command to 
have it displayed. 

3. Click the Cast Iron Analysis  button. 

4. Select the Skip 'Sample information' check box.  

5. Click the Next button. 

 The Materials Solutions tool window displays the next step. 

"Settings" step 

1. Click this button  to set that you want to determine the graphite 
fraction in an unetched sample.  

 If the button for etched samples has been active before, the settings 
possibilities in this window will now change. 

Determination of the 
ferrite/pearlite-ratio 
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2. Use the slide control to define the threshold value for the graphite detection. 
Observe the sample. The threshold value has been correctly set when the 
graphite particles can be completely detected. 

   

 

In the illustration (1), the threshold value has been set too high, the detected 
particles are too coarse. In the illustration (2), the threshold value has been set 
too low, the particles are not detected completely. The illustration (3) shows a 
correctly set threshold value. 

3. Select the graphite parameter that is to be determined. To do so, select the 
corresponding check box. The possibilities listed below are available: Which 
size classes, form classes and form factors are used for the classification, 
depends on the industry standard according to which the cast iron analysis is 
performed. 

 Graphite size: Sorts the detected particles into specific classes, 
according to their size. 

 Graphite form: Sorts the detected particles into specific classes, 
according to their form. 

 Graphite nodularity: Sorts the detected particles into specific 
classes, according to their nodularity. The nodularity is a unit of 
measure for the sphericity of the graphite. 

 Graphite distribution: Makes it possible to compare the 
distribution of the particles in the current image with the 
distribution in specific reference images. When this check box 
has been selected, the additional step, the Graphite distribution 
will be added to the cast iron analysis. 

4. Click the Next button. 

 The Materials Solutions tool window displays the next step. 

"Graphite Distribution" step 
You will only see this step if, in the previous step, you selected the Graphite 
distribution check box. 

In this step, you can compare the particles that have been detected with 
reference images that show different distributions of graphite particles. You can 
then determine which of the reference images shows a distribution that is most 
similar to that of the current image. The reference images correspond to images 
that the chosen standard contains. 
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1. In the Style group, choose how the images are to be arranged in the 
document group for the comparison. Choose an arrangement in which the 
"GlobularGraphite.tif" image and the selected reference image are 

superimposed. To do this, click this  button. 

 In the Overview field, you see the arrangement that has been chosen. 
The reference image you've selected will then be framed in red. 

 

 In the document group, the "Cast Iron Distribution" document will now be 
displayed. It contains exactly one image. 

2. Compare the graphite distribution of the current image with that of the 
reference image. Move the slide control below the Style field in the Opaque 
direction, if the image that is to be checked is to superimpose the reference 
image. Alternatively, move the slide control in the Transparent direction, if the 
image that is to be checked is to be superimposed by the reference image. If 
you want to choose another reference image, in the Overview field, click that 
image with your left mouse button.  

     

The illustration on the left shows the image that is to be checked. Because 
the slide control is located in the direction of the Opaque position, the 
reference image's structures can only be faintly recognized. For the 
illustration on the right, the slide control has been moved in the direction of 
the Transparent position. Now the reference image can be clearly 
recognized, and the image that is to be checked can be only faintly 
recognized. 

3. When you have selected the reference image that is the most similar to the 
image that is to be checked: Click the Accept button. 

 The chosen image's data will be accepted in the Results field.  

 It's possible to accept several reference images, for example, with 
samples that have very different structures. 
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4. Click the Next button. 

 The Materials Solutions tool window displays the next step. 

"Image results" step 
1. Take a look at the results that are shown in the table and also in the image. 

Select the Show graphite detection check box, in the Validation group.  

 Every particle that has been detected will then be outlined with a colored 
line. The color with which the particle is outlined, shows you to which 
class it belongs. The same colors will be used in the chart. 

 

On the left, you see the colored identification of the particles in the image. On the 
right, you see the chart of graphite sizes, that uses the same colors. 

 Particles that have been detected, but that aren't used for the analysis 
(e.g., because they don't come up to the minimum size that has been set 
for the program options), are shown with a dashed line. 

 
2. If you selected several graphite parameters in the Settings step: Toggle 

between the different charts. 

3. If you want to correct the automatically found particles, use the buttons in the 
Validation group. You will find step-by-step instructions on how to correct 
particles in the online help. 

4. Click the Next button. 

"Results" step 
1. Take a look at the results that are shown in the table. Among other things, 

the number of particles is shown here. 

2. Select the Generate Workbook check box to have a document of the 
"workbook" type automatically created at the end of the analysis.  

 Leave the Generate Report and Generate Chart check boxes cleared for 
these step-by-step instructions.  

3. Click the Save sample results button, if you want to also determine the 
ferrite/pearlite-ratio in another cast iron analysis, on the basis of the etched 
sample. You can then load the graphite fraction determined here, and won't 
need to enter it manually. 

4. Click the Finish button. 

 The workbook will be created.  

 The analysis has now been completed. The Materials Solutions tool 
window switches back to the start position. You can now use all of your 
software's functions again. 

00736 
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Performing a cast iron analysis (etched sample) 

You can follow the following step-by-step instructions on your PC. They describe 
how to measure the ferrite/pearlite-ratio. 

"Image source" step 
1. Load the "Ferrite Pearlite.tif" example image. Regarding the information as to 

where the example images are located, please refer to the online help.  

 The ferrite/pearlite-ratio is to be measured. 

2. Activate the Materials Solutions tool window. Should this tool window not be 
visible, use the View > Tool Windows > Materials Solutions command to 
have it displayed. 

3. Click the Cast Iron Analysis  button. 

4. Select the Skip 'Sample information' check box.  

 By doing so, you skip the Sample information step which is not relevant 
for this example image.  
However, it is quite possible that, when performing your own analyses, 
you might want to load sample results (e.g., the result of a previous cast 
iron analysis that determined the graphite fraction ).  
 
In this case, make sure the Skip 'Sample information check box is 
cleared, which will enable you to use the Load sample results button, in 
the Sample information step. 

5. Click the Next button. 

 The Materials Solutions tool window displays the next step. 

"Settings" step 

1. Click this button , to set that you want to determine the 
ferrite/pearlite-ratio, using an etched sample.  

 If the button for unetched samples has been active before, the settings 
possibilities in this window will now change. 

2. Use the Threshold for ferrite slider to define the ferrite phase. By doing so, 
you set the range of intensity values (the phase) that is valid for the ferrite 
detection. If the slide control is closer to the Low position, the phase contains 
a larger part of the intensities that are present in the image.  
 
If the slide control is closer to the High position, the phase contains a smaller 
part of the intensities. This means that only a smaller part of the intensity 
values is detected as ferrite. All of the pixels that have been detected as 
ferrite will be highlighted in yellow in the image. 

3. The threshold value has been correctly set when the ferrite is completely 
detected. 
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In the illustration (1), the threshold value has been set too high, too many 
particles are detected as ferrite.  
 
In the illustration (2), the threshold value has been set too low, the ferrite is not 
detected completely. The illustration (3) shows a correctly set threshold value. 

3. Use the Closing pearlite phase slide control to define how rigid the "voids" 
that the pearlite contains, are to be closed. In this context, a void in the 
pearlite is an area within the pearlite that has so bright intensity values, that it 
is assigned to the ferrite. In the image, voids are visualized as an 
accumulation of small yellow points within the pearlite. 
 
Using the Closing pearlite phase slide control is a means of correcting these 
voids. To do so, a morphological filter is applied. Morphological filters are 
often used in image analysis to optimize the results of an automatic object 
analysis. 

   

In the illustration (1), the pearlite phase is little closed. This is why many voids 
have been detected within the pearlite (see arrows). The illustration (2) shows a 
pearlite phase that is more closed. 

4. In the Graphite fraction group, select how this sample's graphite fraction is to 
be entered.  
The graphite fraction will be subtracted from the detected pearlite fraction. 
Using the pearlite area that has in this way been corrected, the ferrite/pearlite 
ratio is calculated.  
This step is necessary because graphite and pearlite have very similar gray 
values and can therefore not be detected separately by the software.  
 
There are two possibilities how to enter the graphite fraction: 

 You select the Enter manually option and enter the value. This option is 
always active. You can have e.g., made a note of this value, or have 
saved it in a report. 
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 You select the Results of unetched sample analysis option. This option is 
only active if, in the same analysis, you have already measured the 
graphite fraction, using an unetched part of the sample.  
This option is also active if, you measured the graphite fraction in a 
previous analysis, saved these values in a parameter set and loaded 
them in the current analysis' Sample information step.  

5. Click the Next button. 

 The Materials Solutions tool window displays the next step. 

"Image results" step 
1. Take a look at the results that are shown in the table. Among other things, 

here you will find the ferrite/pearlite-ratio that has been measured. 

2. Take a look at the displayed results in the image as well. To do so, select the 
Show ferrite detection check box, in the Validation group.  

 Each detected ferrite particle will now be outlined in yellow.  

 
3. Click the Next button. 

"Results" step 
1. Select the Generate Workbook check box to have a document of the 

"workbook" type automatically created at the end of the analysis.  

 Leave the Create report check box cleared for these step-by-step 
instructions.  

 Leave the Create chart check box cleared for these step-by-step 
instructions. 

2. Click the Finish button. 

 The workbook will be created.  

 The analysis has now been completed. The Materials Solutions tool 
window switches back to the start position. You can now use all of your 
software's functions again. 

00737 
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7.7. What is an inclusion worst field analysis? 
An inclusion worst field analysis is one of several possible procedures used to 
detect non-metallic inclusions in metal samples. This analysis is, e.g., used to 
measure the amount, size and distribution of sulfides and oxides in steel. With 
the measurement results, different production processes can be compared, or 
the quality of a product determined. 

During the production processes, non-metallic inclusions can accrue within steel 
alloys. Inclusions affect the chemical and mechanical properties of the steel. The 
fewer inclusions there are in a steel, and the smaller and homogeneous these 
are, the better is its quality.  

  

 

 

Microscope image of different inclusions in a polished steel sample. The 
inclusions differ in their color and form. The images show a sulfide inclusion (1), 
a silicate inclusion (2), and an aluminum inclusion (3). 

The nature and appearance of the non-metallic inclusions depend on a variety of 
factors, such as, e.g., the steel type, or the production process. The inclusions 
are divided into different classes according to their appearance (color, form, and 
size). The classification is made according to different industry standards. 

What exactly is a non-
metallic inclusion? 
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Since all inclusions are darker than the color of the steel, they can easily be 
detected by means of an automatic image analysis. When detecting the 
inclusions, the inclusion worst field analysis searches for particles.  
 
For the image analysis software, a particle is a cohesive number of pixels, that all 
lie within a defined intensity range. For this reason, you first have to define the 
intensity range. Since between the different inclusions there are also intensity 
differences, (sulfides are, e.g., brighter than oxides), you can also define two 
intensity ranges. 

 

Particle detection during an inclusion worst field analysis. When a suitable 
definition of the gray value ranges has been made, the sulfides (green) and the 
oxides (red) will be detected. 

You can manually edit the inclusions that your software found automatically. You 
have the possibility of deleting, splitting, or joining up inclusions, and you can 
also change their type.  

The inclusion worst field analysis determines which is the largest non-metallic 
inclusion within the sample under investigation. This is done for each inclusion 
type separately.  
The classification and naming convention of the inclusions differs from industry 
standard to industry standard. The sizes are measured in accordance with the 
industry standards: 

 ASTM E 45 Method A 
 DIN 50602 Method M 
 ISO 4967 Method A 
 GB/T 10561 Method A 
 JIS G 0555 Method A 
 UNI 3244 Method M 

The results of an analysis can be displayed in a workbook. Additionally, or 
alternatively to that, the results can be displayed in a MS-Word report. 

00733 

Editing inclusions 

Results of an inclusion 
worst field analysis 
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Performing an inclusion worst field analysis 

You can follow the following step-by-step instructions on your PC. It describes 
how you can detect the worst inclusion in a sample. 

"Image source" step 
1. Load the "NMI0_0.tif" example image. Regarding the information as to where 

the example images are located, please refer to the online help.  

 The largest non-metallic inclusion is to be measured. 

2. Activate the Materials Solutions tool window. Should this tool window not be 
visible, use the View > Tool Windows > Materials Solutions command to 
have it displayed. 

3. Click the Inclusion Worst Field  button. 

4. Select the Skip 'Sample information' check box.  

5. Click the Next button. 

 The Materials Solutions tool window displays the next step. 

"Settings" step 
1. In the Evaluation method field, set the standard you are going to use for the 

analysis. 

2. Use the slide control to define the threshold value for all of the inclusions. 
Observe the sample. The threshold value has been correctly set when the 
inclusions are completely recognized. 

 

The illustration shows a correctly set threshold value. 

3. Since in this sample there are no oxide inclusions, set the Threshold oxide 
inclusions slide control at the position Low. 

4. Select the Show ignored particles check box, when you want to also have the 
particles that weren't included in the analysis shown.  

 Particles will be ignored when they don't fulfill the requirements that were 
specified in the program options. Information on the program options is 
available in the online help.  

5. Click the Next button. 

 The Materials Solutions tool window displays the next step. 
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"Image results" step 
1. Take a look at the results that are shown in the table. Should you have 

analyzed several images of the same sample, you can switch between a 
display of the image results for the current image and the results for all of the 
images. To do this, select either the Image option, or the Sample option, 
located below the table. 

 The table with the measurement results contains a classification of the 
inclusions that have been detected. How this classification looks like, 
depends on the standard by which the analysis was performed. For 
example, the "ASTM E 45 Method A" standard uses the classification A 
(Sulfide), B (Alumina), C (Silicate) and D (Globular Oxide).  
 
Furthermore, this standard groups the inclusions into "t" (thin) and "h" 
(heavy ), according to their mean width (inclusions type A,B,C) or to their 
diameter (inclusions type D). Other standards use another classification 
of the inclusions, and don't further divide them up into groups. 

2. Take a look at the displayed results in the image as well. 

 In the image, every detected inclusion will now be outlined with a colored 
line.  

 

The illustration shows a detected particle. The entire inclusion is outlined with a 
colored line.  

 Particles that have been detected, but that aren't used for the analysis 
(e.g., because they don't come up to the minimum size that has been set 
in the industry standard), are shown with a yellow line. 

3. If you want to correct the automatically found inclusions, use the buttons in 
the Edit inclusions group. You will find step-by-step instructions on how to 
correct inclusions in the online help. 

4. Click the Next button. 

"Results" step 
1. Take a look at the results that are shown in the table. Here you see, for each 

inclusion type separately, the worst inclusion found in any of the analyzed 
images. 

2. Select the Generate Workbook check box to have a document of the 
"workbook" type automatically created at the end of the analysis.  

 Leave the Create report check box cleared for these step-by-step 
instructions.  

3. If you want to save the current settings to a file, click the Save settings to 
file... button. Then assign a descriptive name in the next dialog box. 

4. Click the Finish button. 

 The workbook will be created.  

 The analysis has now been completed. The Materials Solutions tool 
window switches back to the start position. You can now use all of your 
software's functions again. 

00738 
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8. Working with the database 
8.1. Overview - Database 

If you acquire a large number of images with your software, it makes sense to 
save them in a database. All of the file management functions, such as searching 
for images, can be more quickly and easily used in a database, than with files 
that have been saved separately. Your software's database doesn't only save 
images, it also saves all other types of file, for example, text files and results 
sheets. 

Please note: The database isn't available in all OLYMPUS Stream software 
packages. 

This documentation is for the users of a database. Therefore, it is assumed that a 
database has already been set up and configured. 
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8.2. "Database" layout  
When you work with the database you switch to the "Database" layout.  

 Only in this layout is the Database tool window maximized by default. 
Maximizing the tool window has the advantage that it provides you with a 
clearer overview of the database's records, which will help you use all of 
the functions for searching, grouping or editing records optimally. 

 Only in this layout will the document group not be displayed, since, as a 
rule, you won't need to resort to the document group when you are 
working with a database.  

 In the "Database" layout, only those of your image analysis program's 
commands are available that you require when you are working with a 
database. Commands that are not available will be shown in gray. 
Should you want to use one of the commands shown in gray, simply 
switch to another layout. 
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8.3. Tool Window - Database 
The database will be displayed in the Database tool window. This tool window 
gives you access to all of the records that are in the database.  

The Database tool window contains two toolbars. These toolbars provide you 
with access to the most important functions when you're working with a 
database. 

In the Database tool window you can choose between different main views. The 
tool window is differently divided up in every view, and also displays different 

information. Use the first buttons  on the Database tool window's 
lower toolbar to toggle between the main views. The button for the active view 
will appear clicked. You can recognize this status by the button's colored 
background. 

Distinctive features of 
the "Database" layout 

Toolbars in the 
database window 

Main Views in the 
database window 
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The illustration shows the schematic makeup of the Database tool window in the 
various main views (1 = Project View, 2 = Document View, 3 = Search Results 
View). 

(1) Project View: In the Project View you set up new projects or edit already 
existing ones. There, you select the project that you can view and work on in the 
Document View.  

(2) Document View: In the Document View you insert new samples and 
documents into a specific project. There, you can view, work on, or load, already 
existing documents. 

(3) Search Results View: In the Search Results View the results of a database 
search will be displayed. 

The Database window can, as the only tool window, be maximized. To do this, 
click the Maximize  button. You will find this button in the tool window's 
header. This will make almost the whole of your software's user interface 
available for displaying the database. 

In the "Database" layout, the Database tool window is maximized by default. 
Therefore, use the "Database" layout when you are working mainly within a 
database. 

Please note: When the Database tool window is maximized, the document group 
will be covered by the database window. Therefore, many of the commands that 
apply to the document group will, in this case, not be available (e.g., the File > 
Open... command). Should you want to use one of these commands, simply 
switch to another layout.  

When no database has been opened, the Database tool window, offers you the 
commands with which you can open a database, and set up a new database.  
There, you will also find a list of the databases that were last opened. Simply 
click an entry to open the corresponding database. 
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8.4. Overview - Inserting data into a database 
You can insert two different types of data into a database.  

For the better structuring of a database, there are structuring record types, that 
are indicated within the database by a folder icon. A record that belongs to this 
record type isn't referenced to a document, but instead contains only the 
information that is entered in the database fields.  
Structuring records are, e.g., "Projects". They are displayed in the your 
database's Project View.  
Documents are, for example, images, workbooks or diagrams.  
You can of course insert all of the documents that you create with your software, 
or load into it, into a database. You will find an overview of the document types 
that are supported in the online help. 

As well as that, you can, however, also insert any other files that have already 
been saved on a data medium. That applies also to document types that are not 
supported by your image analysis program, e.g., MS-Word documents with the 
file extension DOC.  

Overview - Inserting data into a database 
There are several ways in which you can insert data into a database. Use the 
commands in the Database menu, or from various context menus, or click the 
buttons in the Database tool window. You can also insert documents by 
Drag&Drop. 
All of these possibilities will be described in the text that follows. 

Use the Database > Insert menu commands. The following commands are 
available: 

 Insert Open Documents 
 Insert All Open Documents 
 Insert From Files 

Use one of the buttons located on the Database tool window's upper toolbar.  
 
 

Use the Insert menu in the context menu. You open this context menu by 
rightclicking on one of the following views in the Database tool window. 

 Project List View 
 Sample List View 

You can also insert a single document, for example, an image, directly out of the 
document group into the database. Richtclick the document's title in the 
document bar to open a context menu. The context menu will contain the Insert 
into Database command. 

Drag a document from the MS Windows Explorer into the database gallery. 
To do this, switch to the database's document view. Then select the record into 
which you want to insert the document, in the database. Then drag the document 
from the MS Windows Explorer onto the database gallery. 

When a database has been opened, every image you acquire with your software 
will be automatically saved in the active database. 

Structuring records 

Documents 

Menu commands 

Buttons 

 

Commands from the 
context menu 

Drag&Drop 

Acquiring images 
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Notes on how to insert data into a database 
When you insert records into a database, please pay attention to the points listed 
below: 

You cannot insert records into every database level.  
 

The documents in the database can't be overwritten. If you want to insert a new 
version of a document into the database, you will have to insert the new 
document into the database under a new name, then delete the old document. 

Images that you want to process after the acquisition (e.g., measure) shouldn't 
be inserted into the database until after you have finished working on them. Only 
then will a record be set up exclusively for this image. If you insert image into the 
database immediately after the acquisition, you will have to set up a new record 
when you insert the processed image into the database. 
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8.5. Insert Open Documents 
Use the Database > Insert > Open Documents... command to insert documents 
into the database that have already been opened in your software. A document 
can be an image, but also a workbook or another document.  

The commands are only available when it is at all possible to insert a document. 
Should the command or the button be displayed in gray, check the following 
points.  

 Is a database open?  
 Has, in the database, a record been selected into which you can insert 

documents? 
 Have documents been loaded? 

Inserting documents that have been opened into a database 
1. Load, or create, documents that you want to insert into the current database. 

It doesn't matter whether the documents have already been locally saved or 
not. 
Switch to e.g., the "Acquisition" layout, and acquire an image, or load an 
image from your hard disk.  

2. First select the record into which you want to insert the document, in the 
database. Please note that you cannot insert documents at every database 
level. 

3. Use the Database > Insert > Open Documents... command. 

 The Insert Open Documents dialog box will open. This dialog box lists all 
documents that have been opened. The icon in front of the document 
shows you what type of document it is. 

4. Here, you have to decide whether you want to insert all of the opened 
documents into the database, or only some of them. Select the check box in 
front of each of the documents you want to insert into the database.  

5. Click OK. 

 The Insert <Document Type> dialog box will open successively for each 
of the files you want to insert. The dialog box's appearance depends on 
which type of document you insert into the database. 

 The document will be automatically allotted a name by the database, you 
don't have to take care of that. 

6. Enter the required information in the database fields. Database fields that are 
displayed in bold letters must be filled out. 

The database is 
structured hierarchically 

Data can't be 
overwritten 

Each insertion creates 
a new record 

When is the  
command available? 
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7. Click the Insert button to save the document together with the information 
displayed, in the database. 

 The documents you have inserted will be displayed in the database 
gallery. This process can, especially where large images are concerned, 
take some time. The process is in progress as long as the mouse pointer 
remains in the form of an hourglass.  

Inserting opened documents by Drag&Drop 
1. First select the sample into which you want to insert the document, in the 

database. Please note that you cannot insert documents at every database 
level. 

2. Switch to the "Processing" layout. 

3. Use the View > Tool Windows > Documents command to make the 
Documents tool window appear. 

4. In the Documents tool window, select the documents you want to insert into 
the database.  

5. Drag the documents you've selected onto the database gallery. 
5644 

8.6. Searching for records 
You can search for data in your database at any time you want to. To do so, use 
the Database > Define Search... command. When you search through a 
database, please pay attention to the following points. 

 The database search will always be conducted through the whole 
database.  

 You will find the results of a database search in a special database view, 
the Search Results View. A detailed description of this view can be found 
in the online help.  

 Each new database search overwrites the results of the previous search. 
There are always two ways to search for records.  

 Searching directly for a record 
When you only use a search definition once, specify the search 
conditions with the Database > Define Search... command, and apply it 
directly.  

 Searching in the Search View 
When you want to use the same search definition repeatedly, save the 
search definition and used these saved search definition in the Search 
View. A detailed description of this view can be found in the online help.  

Before you start a search it's advisable to update the view. By updating you will 
make sure that all of the images will be found that at the time of the search are 
located in the database. 
To update the view, use the Database > Views > Update Views command. 

Different search 
possibilities 

Before you start  
your search 
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Searching directly for a record 
1. Use the Database > Define Search... command. 

 The Search Definition dialog box will open. You define the search 
conditions here. 

2. In the Search for group you can limit the search to a few record types. You 
can, for instance, only search for images or for projects. 

3. Define one or more search conditions in the Conditions group. Examples for 
search definitions are available in the online help.  

4. Click the Search button to start the database search.  

 Your software will switch automatically into the database's Search 
Results View. Here only the records that fulfill the current search 
conditions will be displayed. 

There are several ways to leave the Search Results View. 

1. Select a record in the Search Results View.  
Click your right mouse button and select the Go To Record command in the 
context menu. 

 Your image analysis program will then automatically display the sample 
or the project to which the record you've selected belongs. To do this, 
your software will automatically switch to the appropriate database view. 

2. Click the Show Projects  button to switch to the Project View of the 
database. You will find this button on the Database tool window's lower 
toolbar.  

3. Click the Show Documents  button to switch to the Document View of 
the database. You will find this button on the Database tool window's lower 
toolbar.  

Searching in the Search View 
The Database tool window is divided into several areas. In each of these areas, a 
special database view is displayed. In the Search View you can select predefined 
search definitions with which you can carry out a database search.  

In the step-by-step instructions that follow, it will be assumed that search 
definitions that have been saved already exist. Should this not be the case, you 
will find step-by-step instructions on how to create and save a search definition 
further below. 

1. Click the Show Search Results  button to switch to the Search Results 
View of the database. You will find this button on the Database tool window's 
lower toolbar.  

2. Make sure that the Search View is on display. That is the case when the 

Show/Hide Search View  button appears clicked. You will find this button 
on the Database tool window's lower toolbar. 

3. Select the search definition you want from the list next to the Search button. 

 In the Search View, the search conditions will then appear. 

4. Make the necessary entries for the variable search conditions. These 
are, as a rule, different for every database search.  

 The way you have to make the entries can also vary. You may be offered 
a picklist, or a calendar field will appear in which you can select a date. 
Should you be searching for a note, you may in certain cases, have to 
enter the note you're looking for (resp. a part of it), manually.  

Exiting the  
Search Results View 



Working with the database

 

100 

5. Click the Search button. 

 The search will be carried out. As a result of the database search, all the 
records that fulfill the search conditions you've set will be displayed. 

 When a database search has been carried out, the number of records 
that have been found will be shown at the bottom left-hand side of the 
database window. 
The message "26 of 12000 records" means, for example, in the Project 
View, that the database contains a total of 12,000 projects, of which, 26 
fulfill the search conditions. 

Specifying the search conditions for a database search 
1. Use the Database > Define Search... command. 

 The Search Definition dialog box will open. 

2. Specify in the Search for group, which type of record you want to look for. 

3. Define the first search condition in the first line of the Conditions group. 
Examples for possible search definitions are available in the online help. 

 As soon as you have completely defined the first search condition, an 
additional line will appear for an additional search condition.  

4. If necessary, define an additional search condition in the second line. In this 
case you will have to specify the logical link between the two search 
conditions.  
To do this, select one of the logical operators AND or OR in the line's first 
field.  

 With the logical operator AND, both of the search conditions must be 
fulfilled simultaneously, in order for a record to be found with this 
database search. 
With the logical operator OR, only one of the two search conditions has 
to be fulfilled in order for a record to be found. 

5. Save the search definition. To do so, click the Save Search Definition  
button.  

 The Save Search Definition dialog box will open. 

6. Give it a descriptive name, so that you and other users will be able to easily 
recognize the search definition. 

7. Close the open dialog boxes with. 

8. Switch to the Search View and try out the database search. 
00053 
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9. Working with reports 
9.1. Overview - Report 
The report functionality enables you to document the results of your work and to 
make them available to third parties. You can publish reports as a DOC-file or as 
a printout. When a corresponding printer driver is available on your system, you 
can also print reports to a PDF, and send them to other users.  

The illustration shows a report example that is made up of three pages, and 
contains six images.  

 
You have to switch to this layout when working with reports. In this layout, the 
Report Composer tool window, that is required when working with reports, is by 
default displayed. 

The first step when working with reports is always opening or creating a new 
report instruction in your software. In the report instruction, you specify which 
images and which page layout are to be taken for the report. The display and any 
further editing of the created report are done in the MS-Word application 
program. Therefore, this program has to be installed on your PC when you work 
with reports.  

Please note: Two programs are involved in the creation of reports:  
Your software and the MS-Word application program. 

 

 

1.  Create or open a report instruction and fill it with the  
documents you want. 
New report instruction  

 
2.  Create a report. 
Generate Report 

 
3.  In Microsoft Word: Finish the report. 

Working with the Olympus add-In 

 
4.  Save the report instruction and the report. 
Saving the report and the report instruction 
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Process flow when you 

create a report 
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9.2. Working with the report composer 
The Report Composer tool window supports you when you are creating and 
updating report instructions. In this tool window, you will also find the Create 
button that is used to start the report creation. 

Should the Report Composer tool window be hidden, use the View > Tool 
Windows > Report Composer command to make it appear.  

Creating a new report instruction 
To create a report, first create a new report instruction in your software. You can 
also use a saved report instruction. 

The report instruction has to contain at least one registered page template. 
Further information on registering page templates is available in the online help. 

1. Switch to the "Reporting" layout. 

2. Click the New Report Instruction  button. You will find this button in 
the Report Composer tool window. 

 A new document of the "report instruction" type will be created in the 
document group. This document is at the same time the workspace in 
which you put the report together. 

 
3. If no default document template has been defined: Drag the document 

template you want onto the upper part (1) of the report instruction. You will 
find a list of the available document templates in the upper part (2) of the 
Report Composer tool window.  

 If a default document template has been defined, it will be automatically 
inserted in the upper part of the new report instruction.  

 Creating a report is also possible when you leave the upper part of the 
report instruction empty. In this case, the default MS-Word document 
template is used. Normally, this is the "normal.DOT". 

4. Drag the page templates you want onto the lower part of the report 
instruction (3). You will find a list of the available page templates in the lower 
part (4) of the Report Composer tool window.  

 Every report has to contain at least one page template.  

 Make sure that the page templates contain the correct placeholders for 
the document types that you want to drag onto the report instruction. 
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Accordingly, if your report is to contain an image and a chart, select a 
page template that contains one placeholder for an image and another 
for a chart. Further information on page templates is available in the 
online help. 

 If you want to use workbooks in your reports, MS-Excel must be installed 
on your PC. The minimum MS-Excel version required is MS-Excel 2003. 

 The placeholder for a workbook can also be used for a MS-Excel file. In 
this case, you drag a MS-Excel file onto the report instruction, instead of 
dragging a "workbook" file onto it. In the report instruction, MS-Excel files 
are shown with this icon: 

 
5. Drag the documents you want onto the lower part of the report instruction (3).  

 In the "Reporting" layout, you will find the Database, Gallery and File 
Explorer tool windows arranged to the left to the document window. In 
each of the tool windows you can select one or more documents and 
drag them onto the report instruction. If you use the File Explorer tool 
window, the documents do not need to be open for this. If you use the 
Database tool window, the documents don't have to be open either. It is 
sufficient to open the database. However, the Gallery tool window only 
allows you to select documents that are currently open in your software. 

 You can also integrate MS-Word files (e.g., background information 
regarding the project) into your MS-Word reports. As MS-Word files have 
the *.DOC file extension, just as page templates have, they do not 
require a placeholder. If you want to integrate a MS-Word file into the 
report, just drag it onto the report instruction. In the report instruction, 
MS-Word files are shown with this icon: 

. 

 The documents must have been saved, because unsaved documents 
cannot be included in a report. 

 

The illustration shows an example of a report instruction. In the report, two 
different page templates are to be used.  
The first page template contains a single placeholder for an image, the 
second page template contains two placeholders for an image. After the 
page template, the images that are to be inserted in the report page are 
displayed. 

6. Check the report instruction now. You may still edit it and, e.g., delete or shift 
documents or select another page template. 
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Generating a report 

1. Click the Create  button. You will find this button in the Report 
Composer tool window. 

 The report will be created. Creating a report can take some time when 
large reports with many images and documents are involved. Pay 
attention to the progress bar that is shown. The MS-Word application 
program will open automatically and display the new report. In the 
example shown below, the report has three pages. (The fact that the first 
page template only contains one image placeholder and two images 
have been selected in the report instruction, automatically leads to the 
creation of two report pages.) 
 

 
2. If you want to, you can still make additional changes in the MS-Word 

application program. To do so, use the Olympus add-in or the Olympus 
toolbar.  

3. If you want to, save the report instruction and the report. 

Editing a report instruction 
You can make the changes described below to a report instruction. These 
changes do not apply to reports the have already been created on the basis of 
this report instruction. Therefore you must create a new report in order to see the 
changes you made. This will generate a new MS-Word document. Any changes 
that you may have made in the first version of the report will not be contained in 
the newly created DOC-file. 

1. Load the report instruction that you want to edit. 

 Report instructions have the file extension RCI. 

2. To delete a document template, select it and press the [Del]-key on your 
keyboard.  

3. Drag the new document template onto the upper part of the report 
instruction.  

 By doing so, the document template is exchanged. Please note that a 
report instruction can only contain one document template.  

 A report instruction must not contain a document template at all. When 
you leave the upper part of the report instruction empty, the MS-Word 
default document template will be taken. Normally, this is the 
"normal.DOT". 

1. Load the report instruction that you want to edit. 

2. In the report instruction, select the page template you want to exchange.  

3. Use the [Del] key on your keyboard to delete the selected page template 
from the report instruction.  

 By doing so, you only deselect the page template, no file will be deleted. 

Exchanging the 
document template 

Changing the page 
templates 
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4. Drag the new page template to the position in the report instruction, where 
the deleted page template had been located. 

 Every report has to contain at least one page template.  

1. To shift a page template to another place in the report instruction, select it 
and, with the left mouse button depressed, drag it to a new position 
(Drag&Drop). 

 In certain cases, this may change the appearance of the report 
considerably. All documents that come after this page template in the 
report instruction will use this page template in the report. 

1. Load the report instruction that you want to edit. 

2. In the report instruction, select the documents that you want to delete.  

 The standard MS-Windows conventions are valid for the Multiple 
Selection.  

3. Use the [Del] key on your keyboard to delete all of the selected documents in 
the report instruction.  

 By doing so, you only undo the document selection, no file will be 
deleted. 

You can add new documents to an existing report instruction at any time.  

1. Load the report instruction that you want to edit. 

2. Simply drag the new documents onto the position you want in the report 
instruction.  

 Dragging & Dropping images onto the report instruction is possible from 
the Database, Gallery and File Explorer tool windows.  

 Please note the page templates must be placed before the images. 

You can change the order in which the selected documents are arranged in the 
report instruction at any time.  

1. Load the report instruction that you want to edit. 

2. Select an image, and with the left mouse button depressed, drag it to another 
position (Drag&Drop). 

00153 
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9.3. Working with the Olympus MS-Word add-in 
During the installation of your software an add-in from Olympus is added to the 
MS-Word application program (via the global document template 
"OlympusWordReport.dot"). When you start MS-Word you will recognize this 
because the Olympus menu and the Olympus toolbar will be displayed. 

This add-in will help you to carry out important tasks that are necessary when 
working with reports. It will support you with tasks that prepare the report creation 
as well as tasks that are for editing the already created reports.  

Preparatory tasks 
1. You define page templates that you want to use for your reports. For each 

page template you define placeholders for the document types you want. 

During the installation of your software some predefined page templates have 
been installed, too. Please check first whether these predefined page templates 
are already sufficient for your needs before creating your own page templates. 

2. In case you did not insert the placeholders in a chronological order: You 
adjust the insertion order of the placeholders, so that they are numbered 
consecutively, from the first placeholder to the last one. 

Tasks for editing the already created reports in MS-Word 
1. You add a document that is currently open in your software, to a report (or to 

any other DOC-file). 

2. You add a field to your report, so that a certain information that is saved in 
your software, is also displayed in MS-Word. This makes sense, for example, 
 when, exceptionally, you want to see the acquisition date of a certain image 
in the report. 

3. You convert all placeholders in your report. This makes sense, for example, 
 when you want to give the report to third party persons. 

4. You update all placeholders in your report. This makes sense, for example, 
 when you change the documents in your software after the report creation 
and when you now want to see them in the report. 

5. You insert a MS-Word report into the database of your software This 
command is only available if your software supports the database 
functionality. 

Should the Olympus-Word add-in not be on display on your PC, select the Tools 
> Templates and Add-Ins command in MS-Word and, on the Templates tab, 
check whether the "OlympusWordReport.dot" entry has been selected, in the 
Global templates and add-Ins group.  

With the commands from the Olympus Add-In you can also insert documents and 
fields from your software in any MS-Word document that hasn't been set up via 
the Report Composer tool window. In this case, you work mainly in the MS-Word 
application program and you switch to your software only when you want to open 
the documents that you want to insert into the MS-Word document. 

10404 
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9.4. Creating and editing a page template 
 

In a page template placeholders are set up for the documents that the report is to 
contain. There are placeholders for images, charts, workbooks and fields. 

When, for instance, the report is to contain pages that have an image at the top, 
and below it, a chart, you should then set up a page template, which has a 
placeholder for an image and a placeholder for a chart. 

Creating a page template and inserting placeholders 
1. In the MS-Word application program, select the File > New... command. 

2. Select the Empty Document option, if you don't want to use an existing page 
template as template, but instead want to start from scratch. 

3. Select the Olympus > Insert Placeholder command. Decide whether you 
want to insert a placeholder for an image, a chart, or a workbook. Further 
information on workbooks is available in the online help. 

 The placeholder you've selected will be inserted. 

4. If necessary, you can change the size of the placeholder. To do so, move 
your mouse over a handle, then with the left mouse button depressed, drag it 
in the required direction. The length/width ratio remains unchanged, so that 
the objects won't be distorted by this action. 

5. Doubleclick a placeholder for an image, to change the default settings for its 
appearance. 

 The Image properties dialog box opens. Further information is available 
in the online help. 

6. If required, insert additional placeholders for images, charts or workbooks.  

 Make sure that your page template isn't longer than a page. It's better to 
set up two page templates, each of one page, than it is to set up one 
page template that is made up of two pages. 

7. If you want to, you can insert a placeholder for a field. Additional information 
about a placeholder can be shown in this field, for example, the name, or the 
date it was set up. You will find additional information on inserting fields, 
resp. placeholders for fields in the online help. 

8. Save your page templates in the DOC file format. You can choose any 
storage place you like. Don't close the file yet.  

9. In the MS-Word application program, use the File > Properties command, 
and switch to the Summary tab. 

10. Enter a descriptive document title in the Title field. 

 In your software, the page template's document title will be shown in the 
Report Composer tool window, and not the file name. 

11. Select the Save preview picture check box that is located at the bottom of the 
Properties dialog box. 

 Only when this check box has been selected, can your software display 
a preview of the page template. 

12. Close the Properties dialog box with OK, then save, and close the file. 

13. Register the page template in your software. Further information is available 
in the online help. 
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Adjusting the insertion order 
The placeholders are  numbered in the order in which they were inserted. Should 
you have initially set up placeholders for two images, have then decided to put a 
placeholder for a chart right at the top of the page, the insertion order would be 
that shown in the example on the left. When you have used the Olympus > 
Adjust Insertion Order command, the insertion order will be numbered serially 
from top to bottom (see the example on the right). 

      

Inserting a placeholder for a field 
1. In the page template, select the placeholder into which you want to insert a 

field. 

2. Use the Olympus > Insert Placeholder > Field... menu command. 
The Insert Field dialog box will open.  

3. Click the Use Selected Placeholder button. 

 In the Placeholder list, the name of the placeholder into which you want 
to insert a field will appear.  

4. In the Available fields list, select the field that is to be inserted. The entries in 
this list are arranged hierarchically. Click the plus sign to expand the list. 

 Two types of field are available. 
The Document Properties list contains fields that are, by default, in your 
software, managed for this document type. 
The Database fields list contains all of the fields that are available in the 
database for the selected placeholder. For this purpose, a database 
must have been opened. 

5. In the Insert Field dialog box, click the Insert button. 

 The placeholder for a field will then be displayed. You can recognize it by 
the curly blue bracket, and by the field name shown. 

6. If required, move the field to another position in the MS-Word file. By default, 
field values are shown to the left of, or above, the selected placeholder. 

7. If necessary, add placeholders for further fields. 

8. Save the page template. 
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9.5. Editing a report 
 
When you have created a report and want to make some changes in it, before 
doing so, you should decide whether it will be better to make the changes in the 
report (i.e., in MS-Word) or in the report instruction (i.e., in your software). 

Often, it is advisable to change the report instruction first and then create a new 
report. Changes you make in the report instruction are valid for every subsequent 
report that you create with this report instruction. There are numerous changes 
that you can anyway, only make in the report instruction, for example, the 
selection of other page templates. 

Changes that you make in a report, are only valid for that particular report. There 
is also no possible way in which changes that are made in a report can be 
automatically adopted in the report instruction.  

However, there are some cases when it makes sense to make a change only in 
the report, for example when you've created a very large report with a large 
number of documents, and only want to change the order of two images in it. If 
you didn't use a report instruction, you can only edit the report anyway. 

Updating placeholders 
As long as the placeholders have not been converted, the documents that are 
shown in the MS-Word report are linked to the images stored in your image 
analysis software. In MS-Word, use the Olympus > Update Placeholders 
command, to update the report's linked documents and field values. You can 
update all placeholders or only the currently selected placeholder. 

The Update Placeholders command makes it easy to have any changes made to 
the images after the report has been created also shown in the report. Please 
take note that all changes made in your software have to be saved, if they are to 
be displayed when the Update Placeholders command is used. 

 

Example: 
In MS-Word, you open a report that you created some time ago. In the 
meantime, you had changed a lot of images in your image analysis software 
(e.g., added measurements). Now, the report is to be updated so that it shows 
the newest version of all of the images. To do so, you select the Olympus > 
Update Placeholders command and, in the Update Placeholders dialog box, you 
set that all placeholders are to be updated. The edited images will be shown in 
the report now.  

Changing the image display 
When images are transferred to a MS-Word report, the image link is transferred 
as well. This makes it possible to change the image display in a MS-Word report 
(e.g., to scroll the image segment). This is no longer possible with converted 
images.  

Doubleclick the placeholder for the image, to open the Image Properties dialog 
box. Further information on this dialog box is available in the online help. 

Preliminary 
considerations 
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Adjusting documents 
In the MS-Word report, you can select a document from the "image" or "chart" 
type and select the Olympus > Adjust Document command. You will then change 
over to the image analysis software, where you can edit the document and then 
automatically change back to the report. This is no longer possible with 
converted placeholders.  

Basically, the Adjust Document command is similar to the Update Placeholders 
command. The difference is that the Adjust Document command is meant for 
users who mainly use MS-Word for creating reports and who only change over to 
the image analysis software in order to make certain changes to some 
documents.  

Example: 
In the MS-Word application program, you edit a report that contains a lot of 
images. With a certain image you notice that an important measurement is 
missing. Using the Adjust Document command, you change over to the image 
analysis software, add the missing measurement and then change back to MS-
Word in order to continue editing the report. 

1. Open the image in MS-Word and select the image that you want to adjust. 

2. Select the Olympus > Adjust Document menu command. 

 You switch to the image analysis software. If it was closed, it will be 
started and displayed in the foreground.  

 The image that you want to adjust is also opened. In case it is from a 
database that is currently closed, the database will be opened in the 
background. 

The image analysis software is now in a special "adjust-document" mode. In this 
mode, you can only make certain adjustments to the image. This is why a lot of 
other functions are hidden. 

3. Make the required change.  

4. If the image information was changed: Save the image in the image analysis 
software. 

 Some changes made to an image don't have to be saved, e.g., when you 
select another frame in a multi-dimensional image. Other changes have 
to be saved, e.g., adding a measurement. The fact that a change has to 
be saved will be indicated by an asterisk shown behind the file name in 
the document group. 

5. Click the Update Report button. You will find this button in the Adjust 
Document message box that is shown in the foreground. 
 

 

 The MS-Word application program will now be shown in the foreground 
again. The edited image will be displayed. You can now continue to edit 
the report. 

 If your image analysis software was closed before you selected the 
Adjust Document command, it will be closed again. If any images or 
databases had to be opened for this command, they will be closed as 
well.  

Adjusting an image 
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Converting a placeholder 
You can convert images (and other documents) in a MS-Word report. When you 
do this, a new MS-Word document is created. In this document, the link to the 
saved images does no longer exist. These images cannot be updated any 
longer. You recognize a converted report by the fact that the Format Picture 
dialog box opens when you doubleclick on an image (and no longer the Image 
properties dialog box that opens when you doubleclick on a linked image).  

The conversion reduces the file size of the DOC file significantly. A conversion 
makes sense when you wish to send the DOC data to a third person who doesn't 
have access to your image analysis software.  

Should a corresponding printer driver be available on your PC, you can 
alternatively print a report as a PDF file, then send this file to a third person. The 
PDF file is in any case even smaller in size than the DOC file with converted 
images. 

1. In MS-Word, open or create the report in which you want to convert the 
placeholders. 

 If you created a new report or if you changed an existing one: Save the 
report. Only saved reports can be converted. 

2. Select the Olympus > Convert Placeholders menu command. 

3. In the Convert Placeholders message box, click the Convert button. 

 The report with the converted images will be displayed as a new MS-
Word document. You can now save it under a new name and give it to 
other persons.  

 The report with the linked placeholders remains opened. 

Editing a workbook in the report 
Your software supports the handling of workbooks. To create a workbook, open, 
for example, the Measurement and ROI tool window and export a results sheet. 
Further information on workbooks is available in the online help. 

Please note: If you want to use workbooks in your reports, MS-Excel must be 
installed on your PC. The minimum MS-Excel version required is MS-Excel 2003. 

Apart from the "image" and "chart" document type, reports can also contain 
workbooks. A workbook is imported as an Excel object in MS-Word. You can 
further edit it in the report. 

1. In the report, doubleclick on the workbook. 

 You will change into the edit mode. You can recognize it by the fact that 
now the column headers and the row numbers are shown. In edit mode, 
as well as that, you can see all of the workbook's worksheets. 

2. If need be, select the worksheet that you want to edit. 

3. Doubleclick the workbook in order to switch to edit mode. Make the required 
change. 

 When you want to format individual cells differently, select the cell and 
use the Format Cells... command in the context menu. 

 When you want to format the complete worksheet differently, (e.g., other 
font or other background color), select the complete worksheet (e.g., with 
the keyboard shortcut [Ctrl + A]), then select the Format Cells... 
command in the context menu.  

 When you want to hide a column, click on the column's header, then 
select the Hide command in the context menu.  

4. Exit edit mode by clicking in the MS-Word report, outside the workbook. 

Converting a 
placeholder in a report 
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Inserting a document 
In a report (or in any other MS-Word document), you can insert a document at 
any position. When you have, for example, created a report, and while you are 
viewing it, notice that you've forgotten an image, you can retroactively insert it 
into the report. 

1. Use the Olympus > Insert Document... command. 

 The Insert Document dialog box will open.  

2. In the area on the left, select the source the document comes from. You have 
the following possibilities: 

 Select the Open Documents entry if you want to insert a document that is 
currently opened in your software. 

 Select the Database entry if you want to insert a document that is part of 
the currently selected database folder. For this purpose, the database 
must be opened in your software. Should you work with a version of the 
software that doesn't support databases, the Database entry will be 
hidden. 

 Select the File Explorer entry if you want to insert a document that is 
stored on your PC or in your network.  

3. Select the required document in the document preview. Click the Insert 
button. 

 The required document will be inserted into the MS-Word report.  

 The Insert Document dialog box remains open.  

4. Insert further documents now or close the dialog box. 

 The path of all documents that you inserted will be saved. That enables 
you to later update the inserted documents by using the Olympus > 
Update Placeholders command (in case the documents were changed 
after they have been inserted into the report). 

Inserting a field 
You can insert a field into a MS-Word report that describes the image in more 
detail. All of the values that have been saved in your software for this document 
can be displayed in this field. 

1. Select the image in the report to which you want to insert a field. 

2. Use the Olympus > Insert Field... menu command. 

 The Insert Field dialog box will open.  

3. Click the Use Selected Placeholder button. 

 In the Placeholder list, the name of the placeholder into which you want 
to insert a field will appear.  

4. In the Available fields list, select the field that is to be inserted. The entries in 
this list are arranged hierarchically. Click the plus sign to expand the list. 

 Two types of field are available. 
The Document Properties list contains document-specific fields, just as 
they are shown in your software's Properties tool window. 
The Database fields list contains all of the fields that are available in the 
database for the selected image. For this purpose, a database must 
have been opened. 
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5. Check at the bottom of the dialog box, whether a field value is displayed in 
the Field value group. Should the Field value group remain empty, this 
means that the field hasn't been filled out in your software. In this case, 
select another field that has been filled out, instead. 

6. Click the Insert button. 

 The field contents will be displayed in the MS-Word document.  

7. If required, move the field to another position in the MS-Word file. By default, 
field values are shown to the left of, or above, the selected placeholder. 

8. If necessary, add further fields. 

9. Close the Insert Field dialog box. 

10. Save the MS-Word report. 

Should you want to have the contents of a specific field regularly shown in your 
reports, you can already insert this field, (resp. a placeholder for this field) into 
the page template. Then this field will be automatically filled out in every report. 
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